Bug 560383 - (nautilus:2251): Nautilus-Python-WARNING **: g_module_open libpython failed: /usr/lib/libpython2.6.so: cannot open shared object file: No such file or directory
Summary: (nautilus:2251): Nautilus-Python-WARNING **: g_module_open libpython failed: ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus-python
Version: 12
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Patrick Dignan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-31 12:01 UTC by ahmed
Modified: 2010-12-03 23:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-03 23:32:52 UTC
Type: ---


Attachments (Terms of Use)

Description ahmed 2010-01-31 12:01:43 UTC
Description of problem:

I installed tortoisehg-nautilus but I found no additions to the context menu in Nautilus. Digging a bit in .xsession-errors, I found that it was looking for /usr/lib/libpython2.6.so but there was only /usr/lib/libpython2.5.so.1.0. I symlinked it, restarted Nautilus and it worked fine. 

Version-Release number of selected component (if applicable):

# yum info tortoisehg-nautilus
Name       : tortoisehg-nautilus
Arch       : i686
Version    : 0.9.2
Release    : 2.fc12
Size       : 25 k
Repo       : installed
From repo  : updates
[...]

Comment 1 ahmed 2010-01-31 12:06:06 UTC
Correction: there was only /usr/lib/libpython2.6.so.1.0.

Comment 2 Mads Kiilerich 2010-01-31 12:54:41 UTC
tortoisehg-nautilus is just python code executed by the python interpreter in nautilus-python, so it doesn't use libpython but is used by libpython. I will reassign to nautilus-python.

However, I can neither reproduce the problem nor see that anything is wrong.

$ ldd /usr/lib/nautilus/extensions-2.0/libnautilus-python.so|grep py
	libpython2.6.so.1.0 => /usr/lib/libpython2.6.so.1.0 (0xb71b9000)
$ rpm -qf /usr/lib/libpython2.6.so.1.0
python-libs-2.6.2-4.fc12.i686

(BTW: The right way to get /usr/lib/libpython2.6.so is to "yum install" it and get python-devel. That should however not be the solution to this problem.)

ahmed, can you post the exact errors you got in .xsession-errors? 

What is the output of
# rpm -q  python python-devel nautilus-python tortoisehg-nautilus
# rpm -qV python python-devel nautilus-python tortoisehg-nautilus

Comment 3 ahmed 2010-01-31 14:08:56 UTC
== .xsession-errors =========

(nautilus:2251): Nautilus-Python-WARNING **: g_module_open libpython failed: /usr/lib/libpython2.6.so: cannot open shared object file: No such file or directory
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gtk-2.0/gobject/__init__.py", line 26, in <module>
    from glib import spawn_async, idle_add, timeout_add, timeout_add_seconds, \
  File "/usr/lib/python2.6/site-packages/gtk-2.0/glib/__init__.py", line 22, in <module>
    from glib._glib import *
ImportError: /usr/lib/libpyglib-2.0-python.so.0: undefined symbol: PyExc_ImportError

(nautilus:2251): Nautilus-Python-WARNING **: could not import gobject

(nautilus:2251): Nautilus-Python-WARNING **: pygobject initialization failed

(nautilus:2251): Nautilus-Python-WARNING **: nautilus_python_init_python failed


============================

# rpm -q  python python-devel nautilus-python tortoisehg-nautilus == 

python-2.6.2-2.fc12.i686
package python-devel is not installed
nautilus-python-0.5.1-5.fc12.i686
tortoisehg-nautilus-0.9.2-2.fc12.i686


===========================

# rpm -qV python python-devel nautilus-python tortoisehg-nautilus

package python-devel is not installed

Comment 4 ahmed 2010-01-31 14:18:35 UTC
And also on my system:

# ldd /usr/lib/nautilus/extensions-2.0/libnautilus-python.so | grep py

libpython2.6.so.1.0 => /usr/lib/libpython2.6.so.1.0 (0x00578000)

Comment 5 ahmed 2010-01-31 14:28:41 UTC
Fixed in testing?
http://koji.fedoraproject.org/koji/buildinfo?buildID=153506

Comment 6 Mads Kiilerich 2010-01-31 14:36:18 UTC
You say that these xsession-errors came with no /usr/lib/libpython2.6.so present? And that creating a symlink fixed it?

Strange. AFAICS /usr/lib/libpython2.6.so is just reporting that a python import is failing.

Can you reproduce the problem by removing the symlink?

You can try the new build and see if it helps, but I doubt it.

Do you have any non-rpm or non-fedora packages installed?

$ Do this work:
python -c 'from glib import spawn_async'

What is the output of
# rpm -q  gtk2 glib2 pygobject2
# rpm -qV gtk2 glib2 pygobject2

Comment 7 ahmed 2010-01-31 14:49:52 UTC
1) I actually did remove the symlink to reproduce the errors in .xsession-errors.

2) I downloaded http://kojipkgs.fedoraproject.org/packages/nautilus-python/0.5.1/6.fc12/i686/nautilus-python-0.5.1-6.fc12.i686.rpm and installed it with yum (with --nogpgcheck) but the problem still persisted.

3) I have no non-rpm packages but I do have a couple of multimedia packages from RPM Fusion. 

4) "python -c 'from glib import spawn_async'" does work.

5) There:

# rpm -q  gtk2 glib2 pygobject2
gtk2-2.18.6-3.fc12.i686
glib2-2.22.3-2.fc12.i686
pygobject2-2.20.0-1.fc12.i686

#rpm -qV gtk2 glib2 pygobject2 
[returns silently]

Comment 8 Mads Kiilerich 2010-01-31 15:06:25 UTC
I have run out of ideas and will leave it to Patrick, the nautilus-python maintainer.

Comment 9 ahmed 2010-01-31 16:27:10 UTC
Mads, check: https://bugzilla.redhat.com/show_bug.cgi?id=474428 
I apologize for not searching thoroughly before reporting the bug.

*** This bug has been marked as a duplicate of bug 474428 ***

Comment 10 Mads Kiilerich 2010-01-31 17:00:59 UTC
Yes, your report is the same as bug 474428#c2, but 
* I don't think that comment is related to the issue discussed there - better track it here.
* That issue is 64-bit specific, and you are on i686.
* If it was the same issue then it should have been solved with nautilus-python-0.5.1-6.fc12

Comment 11 Patrick Dignan 2010-02-01 00:27:21 UTC
This is not a duplicate of that bug, but I can't replicate, because when I tried installing tortoisehg-nautilus, it makes my nautilus crash.

Comment 12 Mads Kiilerich 2010-02-01 00:36:39 UTC
Patrick, I haven't heard about nautilus crashes before, so please file an issue so we can get that tracked and nailed.

Comment 13 Mads Kiilerich 2010-02-01 00:38:07 UTC
Oh, sorry - bug 560500

Comment 14 Patrick Dignan 2010-07-25 17:47:39 UTC
Is this still an issue?  I'm going to close this in one week, unless otherwise informed.

Comment 15 Bug Zapper 2010-11-03 23:27:41 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 16 Bug Zapper 2010-12-03 23:32:52 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.