Bug 56040 - rpm 4.0.3 with --nodirtokens creates empty package
Summary: rpm 4.0.3 with --nodirtokens creates empty package
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm-build   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-11 16:28 UTC by Need Real Name
Modified: 2008-09-15 20:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-11 16:28:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-11-11 16:28:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13 i686)

Description of problem:
When I specify --nodirtokens to build a pre rpmlib 3.0.4-1 (e.g., Red Hat
6.2) compatible
package, the resulting package does not contain any of the files.  rpm -qlp
does list
them, but the package is very small (10KB rather than the ~1.7MB it should
have had)
and installing it does not really install any of the files.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Simply build some package using --nodirtokens.

Additional info:

running "rpm2cpio package.rpm | cpio --list" yields only "1 block", rather
than
the expected list of files.  Building the same package without
--nodirtokens
yields a fully functional .rpm.

Comment 1 Jeff Johnson 2001-11-20 15:35:27 UTC
FWIW, rpm-4.0.2 has been released for Red Hat 6x,
so that is the "supported" version of rpm at this time.

--nodirtokens appears to work for me in rpm-4.0.3, verified by examining a
binary rpm with hexedit, as I have no machines with pre-rpm-3.0.4
installed.

Perhaps you need an explicit
	%define _noPayloadPrefix	1
to remove the leading "./" prefix  in payload files. rpm itself is prepared
this way.

Comment 2 Need Real Name 2001-11-20 16:53:58 UTC
Did you try "rpm2cpio package.rpm | cpio --list" ?  After building with
--nodirtokens,
all I get is a "1 block" listed, rather than the list of names.  I do have
_noPayloadPrefix
defined as you suggested.

If you wish I can send you the script that builds the empty RPM for me.  I just
didn't
include it right away because It's happened to me to *every* RPM I build with
--nodirtokens...

Comment 3 Bill Hayden 2006-06-15 20:53:21 UTC
I just tested this on Fedora Core 4 using rpm 4.4.1, and it's still broken. 
This bug was closed prematurely.

Comment 4 Peter Åstrand 2008-09-15 20:55:39 UTC
Continued on bug 462391.


Note You need to log in before you can comment on or make changes to this bug.