Bug 56045 - ext3 errors
ext3 errors
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Stephen Tweedie
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-11 16:13 EST by Gerald Teschl
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-13 10:08:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2001-11-11 16:13:38 EST
I have a problem with one box which I just upgraded to 7.2 (it worked
perfectly fine with 7.1 just before).

Now I get messages like
---------------------------------------
Nov  8 05:10:06 ws3 kernel: attempt to access beyond end of device
Nov  8 05:10:06 ws3 kernel: 03:01: rw=0, want=1350676760, limit=3068383
Nov  8 05:10:06 ws3 kernel: EXT3-fs error (device ide0(3,1)):
ext3_readdir: directory #371873 contains a hole at offset 32768
----------------------------------------
over and over in the logs and then the kernel will eventually crash.
Comment 1 Stephen Tweedie 2001-11-13 10:08:48 EST
The error you reported here is a sign that something is corrupt, but it can mean
anything: bad memory, a bad disk, disk controller dying, CPU cache errors, or
random memory scribbles from the kernel.  In the past it has most often been
associated with hardware errors on the motherboard north or south bridge chipsets.

What is your hardware config (especially CPU, motherboard, IDE controller and
disk type)?  Which kernel are you using?  When you say the kernel will
"eventually crash", what do you mean by that?
Comment 2 Gerald Teschl 2001-11-14 12:13:57 EST
Some hardwareinfor:

cpu: AMD Athlon(tm) Processor 700MHz
IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 10)
HD: ST310212A
kernel-2.4.9-13

The system was dead and would only react to the reset button. I looked into
the log and the above massages were the last thing in there. However, it
did not happen again since then. I'll close this bug since it doesn't
seem reproducible right now.

Note You need to log in before you can comment on or make changes to this bug.