Bug 560477 - RescueInterface instance has no attribute 'resetInitializeDiskQuestion'
Summary: RescueInterface instance has no attribute 'resetInitializeDiskQuestion'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 554483 (view as bug list)
Depends On:
Blocks: F13Alpha, F13AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-01-31 22:09 UTC by John Reiser
Modified: 2013-01-10 05:42 UTC (History)
6 users (show)

Fixed In Version: anaconda-13.26-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-24 18:12:01 UTC


Attachments (Terms of Use)

Description John Reiser 2010-01-31 22:09:33 UTC
Description of problem: Rescue mode of install DVD aborts before presenting a shell.


Version-Release number of selected component (if applicable):
anaconda-13.23

How reproducible: every time


Steps to Reproduce:
1. Compose DVD from rawhide of 2010-01-30 (Saturday) and burn to DVD.
2. Boot DVD on machine with previously-installed Fedora partitions, choose Rescue mode, English language, US keyboard, do not start network, Continue to find system to rescue.
3.
  
Actual results:
Traceback (most recent call last):
File "/usr/bin/anaconda", line 803, in <module>
rescue.runRescue(anaconda, instClass)
File "/usr/lib/anaconda/rescue.py", line 298, in runRescue
storage.storageInitialize(anaconda)
File "/usr/lib/anaconda/storage/__init__.py", line 83 in storageInitialize
anaconda.intf.resetInitializeDiskQuestion()
AttributeError: RescueInterface instance has no attribute 'resetInitializeDiskQu
estion'
install exited abnormally [1/1]

eventual Kernel panic - not syncing: Attempted to kill init!


Expected results: shell for Rescue mode


Additional info: $ARCH was x86_64.

Comment 1 Hans de Goede 2010-02-01 10:58:44 UTC
A patch fixing this has been posted by pjones:
https://www.redhat.com/archives/anaconda-devel-list/2010-January/msg00586.html

Assigning to him.

Comment 2 John Reiser 2010-02-04 20:14:33 UTC
Not in anaconda-13.25 of Feb.4, despite being ACKed on Jan.29:
https://www.redhat.com/archives/anaconda-devel-list/2010-January/msg00588.html
and I need it again.

Comment 3 James Laska 2010-02-05 17:06:41 UTC
Greetings John, looks like the patch didn't get pulled into anaconda-13.25, but will be in the next build.

In the meantime, you can confirm the fix by using the updates image located at http://jlaska.fedorapeople.org/updates-560477.img

For information on how to use an updates.img, see http://fedoraproject.org/wiki/Anaconda/Updates.

Comment 4 Jerry Vonau 2010-02-08 14:23:31 UTC
*** Bug 554483 has been marked as a duplicate of this bug. ***

Comment 5 James Laska 2010-02-19 16:23:21 UTC
I've tested the updates.img noted previously, and not encountered this issue.  I'll move this bug to CLOSED RAWHIDE once anaconda-13.27 (or newer) is available for test.

Comment 6 James Laska 2010-02-24 18:12:01 UTC
I'm not able to hit this issue using F-13-Alpha-RC2 (anaconda-13.29).


Note You need to log in before you can comment on or make changes to this bug.