Bug 5606 - vim doesn't handle tags produced by ctags
vim doesn't handle tags produced by ctags
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: ctags (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-05 18:43 EDT by Veillard, Daniel
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 15:46:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Veillard, Daniel 1999-10-05 18:43:54 EDT
unless one add -e to the ctags command line (emacs
compatibility mode)
Comment 1 Preston Brown 2000-02-10 15:46:59 EST
I had no problem using the regular 'tags' file produced by ctags with vim.
However, the TAGS file produced for emacs via the '-e' option worked as well.
This is ctags 3.2, included in 6.0 and later.
Comment 2 khp 2000-03-03 20:34:59 EST
I have the same trouble. I'm on RH 6.1 with vim 5.4 and ctags-3.2-1. The problem
goes away when I do:
:set notagbsearch
or when I generate the tags file outside of vim with the -e option. Since other
bug reports seem to indicate that sort has changed recently to be POSIX
compliant, perhaps vim expects the sorting one way while the new `sort' sorts
another? The question then would be: Can I configure vim to call `sort' with the
right backwards compatible options?

Note You need to log in before you can comment on or make changes to this bug.