Bug 56065 - (SCSI AACRAID) aacraid + ext3 fails to install or creates corrupt install
(SCSI AACRAID) aacraid + ext3 fails to install or creates corrupt install
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-12 07:39 EST by Per Steinar Iversen
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Per Steinar Iversen 2001-11-12 07:39:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
The graphical installation process fails, claiming that glibc is corrupt on
the distribution cd. The text mode install works but the result is a
corrupt install with strange problems such as gawk sometimes failing etc.
This only occurs if ext3 is chosen for the filesystem. ext2 creates no
problems and it is possible to convert to ext3 later on without any further
problems. If the RAID controller is deactivated then there is no problem at
all even with ext3.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Dell Poweredge 2550, PERC 3/Di with BIOS V2.5-0 Build 2991, RedHat 7.2
2.Install. The nice graphic install fail when installing, text mode work
but produces a corrupted install.

Actual Results:  The installed version of RH 7.2 was not usable.

Expected Results:  A nice install

Additional info:

Installing using ext2 filesystems and not ext3 work. The ext2 filesystems
can be converted to ext3 without any problems after installing. This makes
it seem likely that there is some unhappy interaction between the aacraid
module and ext3 during installation.
Comment 1 Michael Fulbright 2001-12-03 17:12:18 EST
Brent could you try and reproduce this please.
Comment 2 Per Steinar Iversen 2001-12-04 04:38:13 EST
I tried installing several times with both RedHat CDs bought in the store and with
CDs burned from ISO files from the net and got exactly the same result every time.

Eventually I installed without aacraid enabled but with software RAID and ext3,
that works very well. Software RAID seems to be faster than the aacraid
controller anyway on this hardware.

The server is in production now and it is not easily possible to test anaconda
any more.
Comment 3 Michael Fulbright 2002-01-16 15:03:29 EST
Sounds like a kernel issue - is this a known problem guys?
Comment 4 Bugzilla owner 2004-09-30 11:39:16 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.