Bug 560678 - virt-manager provides reboot menu option that just gives an error
virt-manager provides reboot menu option that just gives an error
Status: CLOSED DUPLICATE of bug 532216
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2010-02-01 10:36 EST by Ray Strode [halfline]
Modified: 2010-02-26 21:33 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-02-26 21:33:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ray Strode [halfline] 2010-02-01 10:36:56 EST
Right now if I click reboot in virt-manager, I get an ugly error dialog.  On first glance, the dialog looks like an internal error or something.  Apparently, the problem is the underlying stack can't do a soft reboot.

I'd propose one of:

a) If soft reboot fails, pop up a dialog saying something like "We can't do an orderly restart.  Would you like us to pull the plug and plug it back in" (in better words) with a "[ x ] don't ask me again" checkbox


b) Add some hooks in the underlying stack to ask whether or not reboot is likely to work.  Then query those hooks when constructing the menu, and hide the reboot menu item in the case the query comes back false.

It looks really rough around the edges the way it works right now.
Comment 1 Paul Jenner 2010-02-05 16:55:49 EST
Effectively a duplicate of bug #532216 ?
Comment 2 Wade Mealing 2010-02-10 04:44:17 EST
If it can't reboot, just shut the machine down then start it up again.  Why have the button there if it bothers .. arrrgh !.
Comment 3 Cole Robinson 2010-02-26 21:33:20 EST
Yeah, this is one of those things that has just been that way in the UI for so long I've grown accustomed to ignoring it.

Libvirt certainly needs a better way to determine if an API is actually supported, which would be handy in this case. But I think the way to address this is to just fake the reboot option at the libvirt level, so all API users will benefit (more info in bug 496537).

Anyways, duping to 532216.

*** This bug has been marked as a duplicate of bug 532216 ***

Note You need to log in before you can comment on or make changes to this bug.