Bug 56069 - doesn't build with gcc 3.1-0.7
doesn't build with gcc 3.1-0.7
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: ORBit2 (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-12 08:50 EST by Bernhard Rosenkraenzer
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-18 14:40:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2001-11-12 08:50:44 EST
gcc -DHAVE_CONFIG_H -I. -I. -I../../.. -I. -I. -I../../../include 
-I../../../include -I../../../include/orbit/orb-core 
-DORBIT_TYPELIB_DIR=\"/usr/lib/orbit\" -I/usr/include/glib-2.0 
-I/usr/lib/glib-2.0/include -I/usr/include -O2 -march=i386 -mcpu=i686 -c 
corba-typecode.c  -fPIC -DPIC -o .libs/corba-typecode.lo
cc1: warning: changing search order for system directory "/usr/include"
cc1: warning:   as it has already been specified as a non-system directory
corba-typecode.c:142: conflicting types for `TC_null_struct'
../../../include/orbit/orb-core/corba-typecode.h:51: previous declaration 
of `TC_null_struct'
corba-typecode.c:149: conflicting types for `TC_void_struct'
../../../include/orbit/orb-core/corba-typecode.h:52: previous declaration 
of `TC_void_struct'
[...]

It's a 

struct CORBA_TypeCode_struct

vs.

extern const struct CORBA_TypeCode_struct

issue (non-matching declarations). Older compilers just happened not to 
barf on it.

Also, the fact that it uses "-I/usr/include" leads to numerous compiler 
warnings.
Comment 1 Havoc Pennington 2002-02-11 15:40:43 EST
It seems to be building now. The /usr/include stuff is filed separately (against
all the -config scripts)

Note You need to log in before you can comment on or make changes to this bug.