Bug 56070 - RFE: Include fsck.ext2 in netstg1.img/hdstg1.img
Summary: RFE: Include fsck.ext2 in netstg1.img/hdstg1.img
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-12 13:54 UTC by Pekka Pietikäinen
Modified: 2007-03-27 03:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Pietikäinen 2001-11-12 13:54:12 UTC
fsck.ext2 would be quite useful to have available in the ftp/hd install
images.

I noticed the need when upgrading a system to 7.2 and the system
(previously running 7.1) didn't want to unmount cleanly for whatever
reason. The upgrade refused to continue because the filesystem was
uncleanly mounted, and there was no easy way of fixing the situation. 

The workaround I came up with was mknod /tmp/sda5 b 8 5, mount /tmp/sda5
/mnt/sysimage,
/mnt/sysimage/bin/mount -r -o remount /tmp/sda5 (the bootimage mount
doesn't seem to
support -r), /mnt/sysimage/sbin/fsck.ext2 /tmp/sda5, umount /tmp/sda5 and
then the upgrade could continue. Not exactly trivial, but it works.

For 8.x it'll probably be less of an issue, though, as ext3 shouldn't have
this problem.

Comment 1 Jeremy Katz 2002-03-15 01:32:43 UTC
Added in CVS

Comment 2 Michael Fulbright 2002-04-01 23:03:47 UTC
Confirmed in re0401.0.

Comment 3 Red Hat Bugzilla 2006-02-21 18:48:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.