Bug 56074 - "Kernel panic: Invalid or not present host" after loading of qla2x00 driver
Summary: "Kernel panic: Invalid or not present host" after loading of qla2x00 driver
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-12 15:41 UTC by Clay Cooper
Modified: 2007-04-18 16:38 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-01 18:54:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Clay Cooper 2001-11-12 15:41:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2

Description of problem:
On a bordeaux w/ a02 bios, 32GB ram, perc 3/qc, intel 1000/XT, and qlogic 2200.

While installing pensacola ia64 qa1108, VT4 reports "Kernel panic: Invalid
or not present host" after loading qla2x00 and identifying PV650F Luns. 
Machine hangs and no further VT switching is possible.

**Note:  Kernel panics only when storage is attached.  Driver loads fine
with qlogic2200 present but with no attached storage.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install qa1108 on a bordeaux w/ a qlogic2200 and attached PV650F storage
2. Note kernel panic after loading of qla2x00 driver
3.
	

Actual Results:  Install kernel panics after loading qla2x00

Expected Results:  Normal install

Additional info:

Comment 1 Arjan van de Ven 2001-11-12 15:52:09 UTC
Is this ever tried with an older tree ?
(I'm asking because 1) there's a different PCI DMA model in this tree and 2) the
qla2x00 driver doesn't seem to be 64 bit safe, and I'd like to know which one is
the real cause here)

Comment 2 Clay Cooper 2001-11-12 16:01:29 UTC
I received the same kernel panic and hang with RC3.  RC2 also hung, but I didn't
receive the kernel panic and message.

Comment 3 Clay Cooper 2001-11-12 16:57:07 UTC
With qa1108 (and previous releases), smp kernel has no trouble loading qla2x00
driver, identifying luns, and booting after install.  The hang only occurs
during install.

Comment 4 Clay Cooper 2001-11-12 20:58:55 UTC
Correction, I saw a "kernel panic: Invalid or not present host" error during one
of five successive boots.  Error appeared after "starting sendmail" during
service starts.  The four other boots were without error.  Once again, this is
qa1108 (2.4.9-13.3smp).

Comment 5 Michael K. Johnson 2001-11-15 18:37:03 UTC
Did 2.4.9-13.4 make a difference?  I saw you tested 13.4 on this platform
on bug #55833

Comment 6 Michael K. Johnson 2001-12-01 12:49:38 UTC
Please test again with the new qla2200 driver in the latest tree we
sent.

Is this direct-attached or attached through a switch?

Comment 7 Clay Cooper 2001-12-01 18:53:38 UTC
Does not occur during install of qa1129 (2.4.9-17.3smp).
Also, have not seen during subsequent boots.

Comment 8 Clay Cooper 2001-12-01 18:54:24 UTC
Storage is direct-attached.

Comment 9 Michael K. Johnson 2001-12-03 14:29:41 UTC
Good, it sounds fixed.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.