Bug 56084 - After installation, on Hardware Raid device, during the initial reboot, system hangs after freeing memory, and then it streams messages about not being able to access /dev/i2o/hda
After installation, on Hardware Raid device, during the initial reboot, syste...
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-12 13:02 EST by linuxmagic
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-13 13:53:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description linuxmagic 2001-11-12 13:02:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Windows NT 5.0; U)

Description of problem:
Looks like the post installation kernel might work differently with the Adaptec 3200s (with 2 quantum 32 gig drives in hardware RAID 0) 
than the one used during the installation process.  The installation process worked perfectly, but during the reboot cannot access the 
device any longer.
1 GIG Motherboard, 2 GIG ram, Adaptec 3200s, quantum 32 gig drives, 4 partitions, (Swap partition not setup up due to 2 GIG limitiation)
/ 4 GIG
/var 8 GIG
/swap 4 gig
/dsk01 16 GIG

Machine stills answers to sys/req, but simply cannot access the i20 device any longer.
No problems in the event viewer for the Raid Controller card.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install Redhat 7.2
2. Do not select to mount a swap partition
3. Complete installation, and reboot

Actual Results:  Hung with cannot access device messages

Expected Results:  Reboot continue

Additional info:

Server in alternate location, but will send in EXACT error messages if neseccary, but thought I would first check to see if theire were 
outstanding issues with the i2o driver modules supplied with 7.2
Comment 1 linuxmagic 2001-11-12 20:14:31 EST
Changed some hardware around.. Wanted to see if this was related..
Ended upwith a hang on the first attempt attemtping to install the first package
Second time I got a problem transferring disk image tohard drive
It allowed me to retry, and then it went as far as mounting the first couple of packages, and then the installer aborted with a 'This is probably a bug 
message, report it to bugzilla' message, I hit debug and saw that it aborted on a signal 16? Resource busy from python's umount instructions..
Is therei a problem with the 120 driver in 7.2??
Comment 2 linuxmagic 2001-11-12 20:46:19 EST
Fourth time around.. it installed packages for 3-4 minutes.. then triggered a Hard Drive Failure Alarm on the Adaptec 3200s, jept installing for 
another 2 minutes.. then complete system lockup, sys/req didn't even work..
Changed PCI slots, drives and terminators...  Will see what happens next..
Comment 3 linuxmagic 2001-11-13 12:46:40 EST
Well, finally decided to eliminate RAID completely from the equation, although I am still using the Adaptec 3200s controller, which uses the i2o 
driver.  Can't install on a single SCSI drive.. 
Fails .. Still have problems with read/write during the install, and also might have some swap related problems...
2 GIG of memory, tried it with no swap, and 2 gig of swap.. last messages on one of the virtual consoles is 
Moving swap 1000M to 2000M while on virt tty1 I get read/write error messages..
Still looks like either hardware or a problem with the i2o drivers..
Changed drives, ribbons, terminators, slots, interrupts, so only thing left is the controller itself, motherboard, and redhat that haven't changed.
Comment 4 linuxmagic 2001-11-13 13:53:21 EST
Finally got another install to run completely, but immediately after reboot.... Back to the same problem...
Hangs after Freeing Unused Kernel memory 220K, for about 2 minutes, then failures to read from the device..

I basically need to know.. Are there any outstanding issues with 7.2 related to the i2o driver...
Or could this be a generic kernel issue in that version?
Comment 5 linuxmagic 2001-11-13 20:06:21 EST
Well, although Redhat Installation failed in strange ways, and did not always gracefully handle the problem, it seems that it is related to an esoteric 
bug between the Adaptec 3200s and the P3VX motherboard....
The Controller and drives worked correctly in another motherboard...
Closing the bug..

Note You need to log in before you can comment on or make changes to this bug.