Bug 56085 - kernel panics on boot up
kernel panics on boot up
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
athlon Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-12 13:11 EST by Joseph Golden
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 17:02:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Golden 2001-11-12 13:11:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
After the install of RedHat 7.2 on my workstaion, Upon reboot I get the
folowing error;
Kernel Panic : Attempted to kill the idle task!
In Swapper Task - not syncing

Mys sytem is FIC AZ11EA mainboard, with 512 MB ram and a 1.2GHZ Athlon
Thunderbird CPU. I have successfully loaded RedHat 7.1, without this
problem and upgrade the kernel to version 2.4.9, and 2.4.9-13. 
This error appears to only be with RedHat 7.2 and the kernel bundled with it.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.tried several attemps at installs.
2.Installed RH 7.1 and attempted to upgrade to RH 7.2 No joy here
3.Tried other operating systems and no problems. Indicates hardware is good.
	

Actual Results:  1. Same error everytime upon boot up.
2. after upgrade same error occured upon boot up.
3. RedHat 7.1 loaded successfully and upgraded kernel as stated above.
all suscessful. Also Linux Mandrake 8.0 loaded sucessfully, as did
Microsoft Windows 2000 Professional.

Expected Results:  1.The results I have seen were expected after 2 tries.
2.Expected to pass and boot up or at least give me the previous kernel
to boot up in.
3. The results were expected, indicating that hardware is fine, and that
there is a possible bug in the kernel bundled with RedHat 7.2 and the
Athlon Thunderbird processors.

Additional info:

CPU: 0 

   EIP: 0010:[<c02340f4>] 

   EFLAGS: 00010282 

   eax : 00000020 ebx : 07c2d454 ecx : 00000119 edx : 00000001 

   esi : 00098800 edi : c0106000 ebp : 00000c00 esp : c0233fc8 

   ds : 0018 es : 0018 ss : 0018 

   Process Swapper(PID : 0 , Process nr : 0 , StackPage = c0233000) 

   Stack : c0106000 c02344e2 c02143a0 c01d7d0b c02143a0 c0234c7b 07c2d454 

   07c2d454 07c2d454 c03b2bac c7fe0000 00000000 c0214460 c0100175 

   Call Trace : [<c0106000>][<c01d7d0b>][<c01oo175>] 

   Code : 0f 32 0d 00 00 20 00 0f 30 68 21 78 1d c0 e8 27 fd ff 83 

   Kernel Panic : Attempted to kill the idle task! 

   In Swapper Task - not syncing 


Also FYI I am currently running RedHat 7.2 sucessfully on my workstaion at
work, and it has a 900MHZ AMD Duron CPU.
Comment 1 Joseph Golden 2001-11-13 09:49:02 EST
More info as I tried again working for a fix to get my workstation up and
operating sucessfully;

I tried to update my kernel by booting up in the repair mode, and was
unsuccessful to upgrade to the  kernel 2.4.9.13-0.5.athlon.rpm or kernel
2.4.9.13-0.5.i686.rpm, for it required modutils > modutils 2.4.7. So will
attempt again after getting necessary dependencies met.

However I received some different code for the kernel panic, that I wanted to
pass along to you in hopes that it would give you abetter idea, of what is occuring.

Call Trace: [<c01469ef>] [<c013e4ee>] [<c035534>] [<c01345b3>] [<c0106f2B>]
Code: 89 44 99 89 59 14 8b 41 10 8d 50 ff 89 51 10 3b 46 14 71
<1> Unable to handle kernel paging request at virtual address 5ecb1f94

Call Trace: [<c0146fb8>] [<c013ed7c>] [<c013f15ez>] [<c013fbaa>] [<c0133aad>]
[<c0106f2b>]
Code: 8b 44 82 18 0f af 5e 0c 89 42 14 03 5a 0c 40 75 05 8b 02 89
<0> kernel panic: Attempted to kill init!

We are currently looking at this same hardware setup for our Linux servers here
at Computer Sciences Corporation (CSC) and running the most current RedHat Linux
7.2. Thansk for the assist to get us back up operationally.
Comment 2 Arjan van de Ven 2001-11-13 09:52:31 EST
Using "noathlon" as kernel command line option should work around the bios bug
that causes this.
See either the release notes or bug 50040 for more information on how to do this.

Note You need to log in before you can comment on or make changes to this bug.