Bug 56091 - printing fails unless USB printer is built into kernel
printing fails unless USB printer is built into kernel
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-12 14:03 EST by gerry_doris
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-09 11:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested modules.conf file (769 bytes, text/plain)
2002-06-09 11:00 EDT, Need Real Name
no flags Details
dmesg output from working kernel (7.14 KB, text/plain)
2002-06-09 11:03 EDT, Need Real Name
no flags Details

  None (edit)
Description gerry_doris 2001-11-12 14:03:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 95)

Description of problem:
I have been unable to configure my usb HP812C using printconf in Redhat 
7.2.  This is an upgraded 7.1 installation where this printer worked 
correctly.  

printconf cannot find device /dev/usb/lp0.  I entered this device as a 
custom install but when I try and print the test page (after restarting 
lpd) nothing happens.

As a further test I installed both 7.1 and 7.2 as fresh installs on 
another PC (two separate partitions).  I connected the same printer and 
once again I can set it up in 7.1 but not in 7.2.

It prints the test page correctly in 7.1 but rebooting to 7.2 I was still 
unable to setup the printer.  

I am able to print to /dev/lp0 on both local and remote linux printers 
under 7.2.  I can also print to parallel port printers that are smb 
connected.

I have only experienced problems trying to get the usb printer 
configured.  All up2date patches for 7.2 have been applied including the 
last printconf patch.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. In X as root select Printer Configuration
2. Select New 
3. Only /dev/lp0 is shown
4. Click rescan but still no other devices appear (should see /dev/usb/lp0)
5. Select Custom Install and enter /dev/usb/lp0
6. Complete rest of printer setup
7. Select Apply to restart lpd
8. Select Test and pick a test page to print
9. Window appears saying test page was sent to the printer
10. Nothing at all happens
11. Manually restarting lpd or rebooting gives a warning that there is no 
such device as /dev/usb/lp0
	

Actual Results:  No test page is printed.  The printer is not installed 
and cannot be used.

Expected Results:  Should see the test page and be able to use the printer

Additional info:

All up2date patches have been applied including the last rpm's for 
printconf and printconf-gui.

I need a color printer and cannot get by much longer with only black and 
white unless I revert back to 7.1.  I consider this to be a high priority 
problem.
Comment 1 gerry_doris 2001-11-14 14:10:43 EST
The printer is now fixed.  It appears that the print module is not being 
automatically loaded.  I re-compiled the kernel turning on usb printing instead 
of having it loaded as a module.

This has corrected the usb printing problem totally.
Comment 2 Tim Waugh 2002-01-07 12:16:38 EST
Reassigning to kernel component.
Comment 3 Arjan van de Ven 2002-01-07 12:20:32 EST
either kudzu or hotplug should load that component automatically...
Comment 4 Pete Zaitcev 2002-01-07 12:25:08 EST
I suspect it may be in the Trond's domain, but let me check.
Comment 5 gerry_doris 2002-01-09 10:09:35 EST
I'm going from memory now but I believe the problem was that there is a choice 
of one of two different USB adaptors in the kernel config.  One has to be 
selected.  Either the config defaulted to the wrong one or no selection was 
made.  

The printing problem was resolved when I selected the normal USB adaptor.  It 
really didn't have anything to do with whether it was loaded as a module or 
compiled inline.
Comment 6 Pete Zaitcev 2002-01-09 14:27:45 EST
I understand that there may be differences between
uhci (CONFIG_USB_UHCI_ALT) and usb-uhci (CONFIG_USB_OHCI).
In 90% of cases, usb-uhci works when uhci does not.
This is why we ship it. It is possible that the non-default
ALT/JE driver works better for you, I have to find out why
and fix usb-uhci.

Note that Linus personally prefers the ALT/JE driver,
so default config for his kernel builds that instead.

Anyhow, stock Red Hat 7.2 with updates must work. If it does
not, I have to fix it. Make sure that you have got updated
kernel (2.4.9-12 is current), initscripts, and hotplug RPMs.

Please let me know how it works.
Comment 7 Pete Zaitcev 2002-05-28 16:24:32 EDT
So, did the updates work? By now we were through a couple more
kernel erratas. Don't forget other components.
Comment 8 gerry_doris 2002-06-04 15:17:47 EDT
I have now upgraded the system to 7.3 and am using the 2.4.18-4 kernel.  
However, I still cannot use the stock kernel and get it to work with my HP 812C 
USB colour printer.  In fact, I've tried it on two Dell systems each running 
the 2.4.18-3 and 2.4.18-4 kernels as shipped by RH and physically moving the 
printer between the Dell's.  On each system I get the same error that the 
kernel cannot find the printer located on /dev/usb/lp0.

To get it to work I have to recompile the kernel making sure to disable the 
default USB driver choice and select the alternate driver.  

In fact, when using the stock kernel (without the alternative driver) nothing 
related to USB is found on either Dell.  This I assume would follow since the 
default USB driver isn't working.

If you wish I can move the printer over to an IBM system that's running the 
stock 2.4.18-4 kernel to see if it works there?  However, I assume it will 
since that system has a working USB mouse and keyboard.

Gerry
Comment 9 Pete Zaitcev 2002-06-04 15:45:17 EDT
Please attach dmesg outputs from non-working stock kernel,
and from the workaround kernel. Capture them after attempting
to work with the printer. DO NOT DROP dmesg dumps into
the comments box, please.

Also, I would like to see /etc/modules.conf, to check
what alias is set for "usb-controller".
Comment 10 Need Real Name 2002-06-09 11:00:37 EDT
Created attachment 60205 [details]
Requested modules.conf file
Comment 11 Need Real Name 2002-06-09 11:03:43 EDT
Created attachment 60206 [details]
dmesg output from working kernel
Comment 12 Need Real Name 2002-06-09 11:10:18 EDT
I have been trying for the last couple of days to get this bug to reappear.  I
have no idea why but I can't get it to fail.  I have downloaded and installed
fresh rpm's of the 2.4.18-4 kernel and source but it still works correctly.  

I haven't changed anything in the hardware on this system at all.  The only
change that I've noticed is that the module.conf file now has an alias for the
USB controller that I never put there???

In any case, my usb printer is now happily working with the stock kernel and
nothing I can do will cause it to fail.
Comment 13 Pete Zaitcev 2002-06-09 16:15:33 EDT
Curious. But all is well that ends well.

Note You need to log in before you can comment on or make changes to this bug.