Bug 56096 - rpm --rebuild fails in make modules_install with fileutils 4.1.1
rpm --rebuild fails in make modules_install with fileutils 4.1.1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-12 14:57 EST by Bernhard Rosenkraenzer
Modified: 2015-01-04 17:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 23:43:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2001-11-12 14:57:09 EST
make -s INSTALL_MOD_PATH=/var/tmp/kernel-2.4.13-0.5-root modules_install
cp: will not overwrite just-created      
`/var/tmp/kernel-2.4.13-0.5-root/lib/modules/2.4.13-0.5BOOT/kernel/drivers/char/joystick/iforce.o' 
with `iforce.o'


I haven't had the time to debug this completely; it might be a bug in the 
new cp, but I believe it's caused by another intentional 
(POSIX-compliance induced) madness.
Comment 1 Bernhard Rosenkraenzer 2001-11-14 13:01:26 EST
The cp/mv change is intentional; just checked the code. It should give you a 
clue on what's wrong:

              /* Don't let the user destroy their data, even if they try hard:
                 This mv command must fail (likewise for cp):
                   rm -rf a b c; mkdir a b c; touch a/f b/f; mv a/f b/f c
                 Otherwise, the contents of b/f would be lost.
                 In the case of `cp', b/f would be lost if the user simulated
                 a move using cp and rm.
                 Note that it works fine if you use --backup=numbered.  */
              if (command_line_arg
                  && x->backup_type != numbered
                  && seen_dest (dst_path, dst_sb))
                {
                  error (0, 0,
                         _("will not overwrite just-created %s with %s"),
                         quote_n (0, dst_path), quote_n (1, src_path));
                  return 1;
                }

If nothing like that is happening, please let me know so I can debug cp.

Comment 2 Arjan van de Ven 2001-11-14 13:08:17 EST
ifneq "$(strip $(ALL_MOBJS))" ""
        mkdir -p $(MODLIB)/kernel/$(MOD_DESTDIR)
        cp $(ALL_MOBJS) $(MODLIB)/kernel/$(MOD_DESTDIR)$(MOD_TARGET)

so... I doubt that this is the "cp + rm == mv" scenario....

Note You need to log in before you can comment on or make changes to this bug.