Bug 56098 - Fortran doesn't work with g77
Summary: Fortran doesn't work with g77
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-12 20:00 UTC by Bernhard Rosenkraenzer
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-14 18:12:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"hello, world" - the FORTRAN way (59 bytes, text/plain)
2001-11-14 17:10 UTC, Trond Eivind Glomsrxd
no flags Details

Description Bernhard Rosenkraenzer 2001-11-12 20:00:01 UTC
octave fails to detect gcc 3.1's f77 as a compatible compiler:

checking whether g77 is the GNU Fortran compiler... yes
checking g77/f2c compatibility... no
checking for f2c... no
configure: warning: in order to build octave, you must have a compatible  
configure: warning: Fortran compiler or f2c installed and in your path.

This might be caused by a g77 bug; please verify and reassign if 
necessary.

Comment 1 Trond Eivind Glomsrxd 2001-11-14 17:09:26 UTC
gcc-g77-3.1-0.7

gcc bug - it can't even compile the FORTRAN version of "hello, world":
[teg@oslo teg]$ g77 -o hello hello.f
/usr/bin/ld: cannot find -lfrtbegin
collect2: ld returned 1 exit status
[teg@oslo teg]


Comment 2 Trond Eivind Glomsrxd 2001-11-14 17:10:37 UTC
Created attachment 37522 [details]
"hello, world" - the FORTRAN way

Comment 3 Jakub Jelinek 2001-11-14 18:12:43 UTC
Fixed in my gcc31.spec copy, will be in gcc-g77-3.1-0.8.


Note You need to log in before you can comment on or make changes to this bug.