Bug 561001 - Please don't require gnome-packagekit
Please don't require gnome-packagekit
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13blocker-KDE
  Show dependency treegraph
 
Reported: 2010-02-02 08:38 EST by Sebastian Vahl
Modified: 2010-02-02 09:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-02 09:39:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2010-02-02 08:38:06 EST
Description of problem:

Please remove the explicit requirement on gnome-packagekit. Otherwise it will also be pulled onto the KDE Live images besides kpackagekit (and we need the space elsewhere).
Comment 1 Rex Dieter 2010-02-02 08:47:50 EST
This looks like it's not new... setroubleshoot/F-12 branch has this dependency too.  Doesn't seem to be any mention of why/how it's used in the .spec.  Dan?
Comment 2 Sebastian Vahl 2010-02-02 08:50:57 EST
This was added on Fri Jan 22 (rev 1.189)

http://cvs.fedoraproject.org/viewvc/rpms/setroubleshoot/devel/setroubleshoot.spec?r1=1.189&r2=1.190
Comment 3 Daniel Walsh 2010-02-02 09:39:34 EST
It is using gnome-packagekit to figure out what version of selinux policy is installed and whether or not it needs an update.

Although it looks like it is no longer used so I can remove.  It is now using yum.

Fixed in setroubleshoot-2.2.62-1.fc13

Note You need to log in before you can comment on or make changes to this bug.