Bug 561031 - SELinux is preventing /usr/bin/python "search" access on /root/.local.
Summary: SELinux is preventing /usr/bin/python "search" access on /root/.local.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:e41ed57a844...
: 562087 562599 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-02 14:34 UTC by Ulrich Walczak
Modified: 2015-04-17 11:54 UTC (History)
19 users (show)

Fixed In Version: 3.6.32-84.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-11 14:43:47 UTC


Attachments (Terms of Use)

Description Ulrich Walczak 2010-02-02 14:34:31 UTC
Summary:

SELinux is preventing /usr/bin/python "search" access on /root/.local.

Detailed Description:

SELinux denied access requested by system-config-f. It is not expected that this
access is required by system-config-f and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:firewallgui_t:s0-s0:c0.c1023
Target Context                system_u:object_r:gconf_home_t:s0
Target Objects                /root/.local [ dir ]
Source                        system-config-f
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.6.2-2.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-78.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.12-174.2.3.fc12.i686.PAE
                              #1 SMP Mon Jan 18 20:06:44 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Tue 02 Feb 2010 02:03:50 PM GMT
Last Seen                     Tue 02 Feb 2010 02:03:50 PM GMT
Local ID                      024612e1-25ca-424d-8fb5-2065a8adc7a7
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1265119430.231:74): avc:  denied  { search } for  pid=3090 comm="system-config-f" name=".local" dev=dm-0 ino=163959 scontext=system_u:system_r:firewallgui_t:s0-s0:c0.c1023 tcontext=system_u:object_r:gconf_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1265119430.231:74): arch=40000003 syscall=195 success=no exit=-2 a0=91bac48 a1=bfaf2d6c a2=280ff4 a3=91bac48 items=0 ppid=3089 pid=3090 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="system-config-f" exe="/usr/bin/python" subj=system_u:system_r:firewallgui_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-78.fc12,catchall,system-config-f,firewallgui_t,gconf_home_t,dir,search
audit2allow suggests:

#============= firewallgui_t ==============
allow firewallgui_t gconf_home_t:dir search;

Comment 1 Daniel Walsh 2010-02-02 14:52:24 UTC
optional_policy(`
	gnome_read_gconf_home_files(firewallgui_t)
')

Comment 2 Miroslav Grepl 2010-02-02 17:42:01 UTC
Fixed in selinux-policy-3.6.32-81.fc12

Comment 3 Fedora Update System 2010-02-03 23:21:39 UTC
selinux-policy-3.6.32-82.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-82.fc12

Comment 4 Fedora Update System 2010-02-05 01:46:17 UTC
selinux-policy-3.6.32-84.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1492

Comment 5 Miroslav Grepl 2010-02-05 08:56:27 UTC
*** Bug 562087 has been marked as a duplicate of this bug. ***

Comment 6 Miroslav Grepl 2010-02-08 09:47:59 UTC
*** Bug 562599 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2010-02-11 14:39:26 UTC
selinux-policy-3.6.32-84.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.