Bug 561050 - [abrt] crash in rst2pdf-0.12.2-2.fc12
Summary: [abrt] crash in rst2pdf-0.12.2-2.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rst2pdf
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Sergio Pascual
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:be05a0c3
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-02 15:09 UTC by Sjoerd Mullender
Modified: 2010-02-23 05:29 UTC (History)
1 user (show)

Fixed In Version: rst2pdf-0.12.3-2.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-23 05:27:39 UTC


Attachments (Terms of Use)
File: backtrace (1.21 KB, text/plain)
2010-02-02 15:09 UTC, Sjoerd Mullender
no flags Details

Description Sjoerd Mullender 2010-02-02 15:09:45 UTC
abrt 1.0.4 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/rst2pdf ontruiming-2010-03-01.rst
component: rst2pdf
executable: /usr/bin/rst2pdf
kernel: 2.6.31.12-174.2.3.fc12.x86_64
package: rst2pdf-0.12.2-2.fc12
release: Fedora release 12 (Constantine)

backtrace
-----
Summary: TBbe05a0c3 pkg_resources.py:524:resolve:DistributionNotFound: docutils

Traceback (most recent call last):
  File "/usr/bin/rst2pdf", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2562, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 626, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 524, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
DistributionNotFound: docutils

Local variables in innermost frame:
dist: None
to_activate: [rst2pdf 0.12.2 (/usr/lib/python2.6/site-packages), Pygments 1.1.1 (/usr/lib/python2.6/site-packages), reportlab 2.3 (/usr/lib64/python2.6/site-packages)]
req: Requirement.parse('docutils')
requirements: [Requirement.parse('setuptools')]
processed: {Requirement.parse('reportlab>=2.1'): True, Requirement.parse('rst2pdf==0.12.2'): True, Requirement.parse('Pygments'): True}
env: <pkg_resources.Environment object at 0x7f0b10fd9650>
installer: None
self: <pkg_resources.WorkingSet object at 0x7f0b10fd9090>
best: {'docutils': None}

comment
-----
I installed rst2pdf with its dependencies and then ran it.  This resulted in the eclosed backtrace.
The reason is that python-docutils wasn't installed.  It is apparently not required by the rst2pdf RPM, even though it is needed by the program.
rst2pdf ran fine after I also installed python-docutils.

How to reproduce
-----
1.yum install rst2pdf
2.rst2pdf file.rst
3.

Comment 1 Sjoerd Mullender 2010-02-02 15:09:48 UTC
Created attachment 388329 [details]
File: backtrace

Comment 2 Fedora Update System 2010-02-02 16:25:58 UTC
rst2pdf-0.12.3-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rst2pdf-0.12.3-2.fc12

Comment 3 Fedora Update System 2010-02-02 16:27:50 UTC
rst2pdf-0.12.3-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rst2pdf-0.12.3-2.fc11

Comment 4 Fedora Update System 2010-02-05 01:34:00 UTC
rst2pdf-0.12.3-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rst2pdf'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1472

Comment 5 Fedora Update System 2010-02-05 01:47:45 UTC
rst2pdf-0.12.3-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rst2pdf'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-1499

Comment 6 Fedora Update System 2010-02-23 05:27:34 UTC
rst2pdf-0.12.3-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2010-02-23 05:29:41 UTC
rst2pdf-0.12.3-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.