Bug 561059 - [abrt] crash in fwbuilder-3.0.7-1.fc12
Summary: [abrt] crash in fwbuilder-3.0.7-1.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libfwbuilder
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ralf Ertzinger
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ab4b8f8372252241e2765d6e7a4...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-02 15:41 UTC by Juan Pablo Lorier
Modified: 2010-02-16 13:07 UTC (History)
3 users (show)

Fixed In Version: 3.0.7-2.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-16 13:07:49 UTC


Attachments (Terms of Use)
File: backtrace (48.29 KB, text/plain)
2010-02-02 15:41 UTC, Juan Pablo Lorier
no flags Details

Description Juan Pablo Lorier 2010-02-02 15:41:45 UTC
abrt 1.0.4 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: fwbuilder
component: fwbuilder
executable: /usr/bin/fwbuilder
kernel: 2.6.31.12-174.2.3.fc12.i686.PAE
package: fwbuilder-3.0.7-1.fc12
rating: 4
reason: Process was terminated by signal 6 (Aborted)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1.open an existing configuration file
2.
3.

Comment 1 Juan Pablo Lorier 2010-02-02 15:41:50 UTC
Created attachment 388336 [details]
File: backtrace

Comment 2 Ralf Ertzinger 2010-02-02 15:54:08 UTC

*** This bug has been marked as a duplicate of bug 532307 ***

Comment 3 Michal Schmidt 2010-02-02 22:38:31 UTC
Bug 532307 is similar to this one, but they're not duplicates. It's just that fwbuilder misuses the xmlCleanupParser() function like Empathy did. More exactly, it's not fwbuilder itself, but libfwbuilder:

$ grep -r xmlClean libfwbuilder-3.0.7
libfwbuilder-3.0.7/src/fwbuilder/FWObjectDatabase.cpp:        xmlCleanupParser();
libfwbuilder-3.0.7/src/fwbuilder/FWObjectDatabase.cpp:    xmlCleanupParser();
libfwbuilder-3.0.7/src/fwbuilder/FWObjectDatabase.cpp:    xmlCleanupParser();
libfwbuilder-3.0.7/src/fwbuilder/XMLTools.cpp:            xmlCleanupParser();
libfwbuilder-3.0.7/src/fwbuilder/XMLTools.cpp:            xmlCleanupParser();
libfwbuilder-3.0.7/src/fwbuilder/XMLTools.cpp:    xmlCleanupParser();
libfwbuilder-3.0.7/src/fwbuilder/XMLTools.cpp:    xmlCleanupParser();
libfwbuilder-3.0.7/src/fwbuilder/XMLTools.cpp:    xmlCleanupParser();
libfwbuilder-3.0.7/src/fwbuilder/XMLTools.cpp:        xmlCleanupParser();
libfwbuilder-3.0.7/src/fwbuilder/XMLTools.cpp:            xmlCleanupParser();
libfwbuilder-3.0.7/src/fwbuilder/XMLTools.cpp:            xmlCleanupParser();
libfwbuilder-3.0.7/src/fwbuilder/XMLTools.cpp:        xmlCleanupParser();
libfwbuilder-3.0.7/src/fwbuilder/XMLTools.cpp:            xmlCleanupParser();
libfwbuilder-3.0.7/src/fwbuilder/XMLTools.cpp:            xmlCleanupParser();
libfwbuilder-3.0.7/src/fwbuilder/XMLTools.cpp:            xmlCleanupParser();

Comment 4 Fedora Update System 2010-02-05 19:51:51 UTC
libfwbuilder-3.0.7-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libfwbuilder-3.0.7-2.fc12

Comment 5 Fedora Update System 2010-02-09 04:58:24 UTC
libfwbuilder-3.0.7-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libfwbuilder'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1553

Comment 6 Fedora Update System 2010-02-16 13:07:44 UTC
libfwbuilder-3.0.7-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.