Bug 561094 - copying the /etc/dhcp.conf file creates a confusing setup
copying the /etc/dhcp.conf file creates a confusing setup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-02 12:20 EST by Till Maas
Modified: 2010-02-11 09:45 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.1.1-5.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-11 09:45:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2010-02-02 12:20:00 EST
Description of problem:
dhcp copies /etc/dhcp.conf to /etc/dhcp/dhcp.conf after installation, which leaves a confusing setup, because changes to /etc/dhcp.conf are not used by dhcpd.
It would be more obvious, if /etc/dhcp.conf would be also moved to e.g. /etc/dhcp.conf.rpmsave or similiar to show, that it is not used anymore. Or not to copy it at all would also be an option.

Version-Release number of selected component (if applicable):
dhcp-4.1.0p1-17.fc12

How reproducible:
always

Steps to Reproduce:
1. create a /etc/dhcp.conf file
2. install dhcp

  
Actual results:
/etc/dhcp.conf is copied to /etc/dhcp/dhcp.conf, /etc/dhcp.conf stays unchaged.

Expected results:
It should be made obvious that /etc/dhcp.conf is no longer used
Comment 1 Fedora Update System 2010-02-04 20:41:50 EST
dhcp-4.1.1-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0928
Comment 2 Fedora Update System 2010-02-09 00:10:06 EST
dhcp-4.1.1-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0928
Comment 3 Fedora Update System 2010-02-11 09:45:00 EST
dhcp-4.1.1-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.