Bug 56114 - fsck.minix seems broken on s/390
fsck.minix seems broken on s/390
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.3
s390 Linux
medium Severity low
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-12 16:34 EST by Ben Levenson
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-23 20:28:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fsck.minix strace-interrupted by killing ssh session (after 5+ minutes) (5.02 KB, text/plain)
2001-11-12 16:53 EST, Ben Levenson
no flags Details

  None (edit)
Description Ben Levenson 2001-11-12 16:34:58 EST
Description of Problem:
fsck.minix hangs on s390.
strace attached.

Version-Release number of selected component (if applicable):
util-linux-2.11f-15
cat /proc/version:
Linux version 2.4.9-9.1 (harald@s390.redhat.de) (gcc version 2.95.3
20010315 (release)) #1 SMP Wed Oct 31 15:33:39 CET 2001


How Reproducible:
100%

Steps to Reproduce:
1. dd if=/dev/zero of=/tmp/minix.img bs=1M count=10
2. mkfs.minix /tmp/minix.img
(3. mount /tmp/minix.img. copy a couple of files. unmount. <-- just did 
 this to verify the functionality of the minix.img, though it is not a
 necessary step to recreate the failure)
4. fsck.minix -lavsmf /tmp/minix.img

Actual Results:
shell hangs...

Expected Results:Forcing filesystem check on /tmp/minix.img.
(these are the results from repeating the steps on i686)
3424 inodes
10240 blocks
Firstdatazone=112 (112)
Zonesize=1024
Maxsize=268966912
Filesystem state=1
namelen=30

     2 0100644   1 /sanity
     3 0100755   1 /sanity_color
     4 0100644   1 /sanity.kdeadmin
     5 0100644   1 /sanity.man-pages
     6 0100644   1 /sanity.mpage

     6 inodes used (0%)
   146 zones used (1%)

     5 regular files
     1 directories
     0 character device files
     0 block device files
     0 links
     0 symbolic links
------
     6 files



Additional Information:
The process can't be interrupted w/ <^-C> or w/ kill -9 <pid>.
Comment 1 Ben Levenson 2001-11-12 16:53:37 EST
Created attachment 37302 [details]
fsck.minix strace-interrupted by killing ssh session (after 5+ minutes)
Comment 2 Bernhard Rosenkraenzer 2001-11-14 05:39:59 EST
Since it's hanging in a sync() call, it looks suspiciously like a kernel 
problem. Any ideas, Arjan?
Comment 3 Arjan van de Ven 2001-11-14 05:46:08 EST
does the same happen with fsck.ext2 ?
Comment 4 Harald Hoyer 2001-11-14 06:26:15 EST
maybe kupdated died again...
Comment 5 Ben Levenson 2001-11-14 12:25:44 EST
will try fsck.ext2 once the s/390 is back online.
Comment 6 Ben Levenson 2001-11-14 12:26:43 EST
didn't mean to change to assigned...
switching back to NEEDINFO
Comment 7 Karsten Hopp 2001-11-14 12:51:16 EST
removed s/390 minix support in newest util-linux, but fsck.ext2 needs to be 
checked
Comment 8 David Sainty 2001-11-23 20:28:47 EST
I've never seen a problem w/ fsck.ext2 / e2fsck.
Comment 9 David Sainty 2001-11-30 12:01:24 EST
Exact steps followed in original report for ext2 - no problems.  Creating and
checking ext[23] fs's has been one of the things tested very regularly. No
problems are known.  Closing.

Note You need to log in before you can comment on or make changes to this bug.