Bug 561235 - Review Request: phpesp - PHP-based survey web application
Summary: Review Request: phpesp - PHP-based survey web application
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Hiemanshu Sharma
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-03 05:49 UTC by David Nalley
Modified: 2010-05-04 06:24 UTC (History)
3 users (show)

Fixed In Version: phpesp-2.1.1-2.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-04 06:03:22 UTC
hiemanshu: fedora-review+
tibbs: fedora-cvs+


Attachments (Terms of Use)

Description David Nalley 2010-02-03 05:49:53 UTC
Spec URL: http://ke4qqq.fedorapeople.org/phpesp.spec
SRPM URL: http://ke4qqq.fedorapeople.org/phpesp-2.1.1-1.fc12.src.rpm
Description: 
PHP scripts to let non-technical users create surveys, administer surveys,
gather results, view statistics. All managed online after database
initialization.


rpmlint complains about a dangling symlink, but this is a false positive.

Comment 1 David Nalley 2010-02-11 17:26:32 UTC
[ke4qqq@nalleyx60 SPECS]$ rpmlint ./phpesp.spec 
0 packages and 1 specfiles checked; 0 errors, 0 warnings.
[ke4qqq@nalleyx60 SPECS]$ rpmlint ../SRPMS/phpesp-2.1.1-1.fc12.src.rpm 
1 packages and 0 specfiles checked; 0 errors, 0 warnings.
[ke4qqq@nalleyx60 SPECS]$ rpmlint ../RPMS/noarch/phpesp-2.1.1-1.fc12.noarch.rpm 
phpesp.noarch: W: dangling-symlink /usr/share/phpesp/admin/include/lib/adodb /usr/share/php/adodb
1 packages and 0 specfiles checked; 0 errors, 1 warnings.

Comment 2 Hiemanshu Sharma 2010-02-11 18:54:26 UTC
- Package meets naming guidelines
0 Spec file matches base package name.
0 Spec has consistant macro usage.
- Meets Packaging Guidelines.
0 License
0 License field in spec matches
0 License file included in package
0 Spec in American English
0 Spec is legible.
0 Sources match upstream md5sum:
  9d5e68fa1af1f4d91da34e76ed95fe19  phpESP-2.1.1.tgz
* Package needs ExcludeArch
0 BuildRequires correct
* Spec handles locales/find_lang
* Package is relocatable and has a reason to be.
0 Package has %defattr and permissions on files is good.
0 Package has a correct %clean section.
x Package has correct buildroot
%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
0 Package is code or permissible content.
* Doc subpackage needed/used.
0 Packages %doc files don't affect runtime.

* Headers/static libs in -devel subpackage.
* Spec has needed ldconfig in post and postun
* .pc files in -devel subpackage/requires pkgconfig
* .so files in -devel subpackage.
* -devel package Requires: %{name} = %{version}-%{release}
* .la files are removed.

* Package is a GUI app and has a .desktop file

0 Package compiles and builds on at least one arch.
0 Package has no duplicate files in %files.
0 Package doesn't own any directories other packages own.
0 Package owns all the directories it creates.
0 No rpmlint output. [False Positive]
0 final provides and requires are sane:
Provides:
phpesp-2.1.1-1.fc12.noarch.rpm
config(phpesp) = 2.1.1-1.fc12
phpesp = 2.1.1-1.fc12
Requires:
/bin/sh  
/usr/bin/perl  
config(phpesp) = 2.1.1-1.fc12
perl(strict)  
php >= 4.2.1
php-adodb  
php-gettext  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
webserver  
rpmlib(PayloadIsXz) <= 5.2-1

SHOULD Items:

- Should build in mock.
0 Should build on all supported archs
0 Should function as described.
0 Should have sane scriptlets.
* Should have subpackages require base package with fully versioned depend.
0 Should have dist tag
0 Should package latest version
* check for outstanding bugs on package. (For core merge reviews)

[-] To be checked
[x] Need fixing
[*] NA
[0] Checked

Comment 3 David Nalley 2010-02-13 00:54:02 UTC
Hiemanshu: 

I may have overlooked other things, but the one thing I see as a fix, is buildroot. 
When I look at the Packaging Guidelines here http://fedoraproject.org/wiki/PackagingGuidelines#BuildRoot_tag  my buildroot seems to look acceptable though not the most preferred. 
If you still want this changed, let me know. 

Thanks

Comment 4 Hiemanshu Sharma 2010-02-19 12:00:35 UTC
Please fix it before I can continue

- Hiemanshu Sharma

Comment 6 David Nalley 2010-02-28 04:53:07 UTC
Per our conversation in irc: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=2018829

Comment 7 Hiemanshu Sharma 2010-02-28 05:04:56 UTC
The package looks good to me. Approved.

- Hiemanshu

Comment 8 David Nalley 2010-02-28 19:35:43 UTC
Thanks for the review Hiemanshu!!!


New Package CVS Request
=======================
Package Name: phpesp
Short Description: PHP-based web survey application
Owners: ke4qqq
Branches: F-11 F-12 EL-5
InitialCC:

Comment 9 Jason Tibbitts 2010-03-01 16:57:52 UTC
CVS done (by process-cvs-requests.py).

I added an F-13 branch since that seems to have been left out.

Comment 10 Fedora Update System 2010-03-08 15:47:11 UTC
phpesp-2.1.1-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/phpesp-2.1.1-2.fc11

Comment 11 Fedora Update System 2010-03-08 15:47:17 UTC
phpesp-2.1.1-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/phpesp-2.1.1-2.fc12

Comment 12 Fedora Update System 2010-03-10 06:40:52 UTC
phpesp-2.1.1-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update phpesp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/phpesp-2.1.1-2.fc11

Comment 13 Fedora Update System 2010-03-10 06:41:18 UTC
phpesp-2.1.1-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update phpesp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/phpesp-2.1.1-2.fc12

Comment 14 Fedora Update System 2010-05-04 06:03:17 UTC
phpesp-2.1.1-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2010-05-04 06:24:24 UTC
phpesp-2.1.1-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.