This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 561251 - Apache: Error message should be thrown if http url is provided against the error type 401
Apache: Error message should be thrown if http url is provided against the er...
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
1.4
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Filip Drabek
: SubBug
Depends On:
Blocks: rhq_spearhead jon24-apache
  Show dependency treegraph
 
Reported: 2010-02-03 02:34 EST by Sunil Kondkar
Modified: 2010-04-26 05:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 05:20:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sunil Kondkar 2010-02-03 02:34:30 EST
Description of problem:
If user provides http url against the error type 401 in 'Document' field in 'Error Document' section, it is saved without any error message. A proper error message should be thrown as a full URL cannot be used in a 401 ErrorDocument directive.

Version-Release number of selected component (if applicable):
1.4.0-SNAPSHOT

How reproducible:


Steps to Reproduce:

1. Login to imanage UI.
2. Navigate to the apache httpd resource.
3. Navigate to the 'Configuration' tab of main server.
4. Click on 'Edit' button.
5. Click on 'Add New' button for 'Error Document' section.
6. Enter '401' in 'HTTP Response Code' field.
7.Enter the http url against the error type 401 in 'Document' field. (Ex: http://www.abc.com/pqr.html)
8.Click OK button.
9.Click 'Save' button.
  
Actual results:
If user provides http url against the error type 401 in 'Document' field in 'Error Document' section, it is saved without any error message.

Expected results:
A proper error message should be thrown as a full URL cannot be used in a 401 ErrorDocument directive.

Additional info:
Comment 1 wes hayutin 2010-02-16 11:58:04 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 2 wes hayutin 2010-02-16 12:02:59 EST
making sure we're not missing any bugs in rhq_triage
Comment 3 Charles Crouch 2010-04-23 08:52:54 EDT
Filip
First thing to know is what are the valid values for the ErrorDocument and then consider if we can add validation to detect non-valid ones.
Comment 4 Sunil Kondkar 2010-04-26 05:20:23 EDT
As per ErrorDocument directive - Apache can be configured to redirect to an external URL to handle the problem/error. So the test case needs to be updated.
Closing as this is not a bug.

Note You need to log in before you can comment on or make changes to this bug.