Bug 561259 - weird spacing effect when using liberation mono size 9 font
weird spacing effect when using liberation mono size 9 font
Status: CLOSED DUPLICATE of bug 508899
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-03 03:23 EST by Arkadiusz Miskiewicz
Modified: 2010-02-03 03:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-03 03:33:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
video showing the problem (118.30 KB, application/x-ogg)
2010-02-03 03:23 EST, Arkadiusz Miskiewicz
no flags Details

  None (edit)
Description Arkadiusz Miskiewicz 2010-02-03 03:23:10 EST
Created attachment 388469 [details]
video showing the problem

Description of problem:

I was using liberation mono font from 1.04.93 package withtout a problem.
After switching to 1.05.2.20091227 (ttf version, prebuild by upstream) weird spacing things started to happen. Some spacing started to appear
between letters/chars and cursor but only few specific letters/characters.
The rest is displayed fine.


Version-Release number of selected component (if applicable):

1.05.2.20091227

How reproducible:

Always.


Steps to Reproduce:
1. run KDE konsole terminal
2. set font liberation mono size 9
3. start writting long line by using single character from the characters below:
- d g q H N "
  
Actual results:

When writting long line of "dddddd" this starts to look like:
"dddddddd          <cursor>"
and now writting some next letter gives us:
"dddddddda          <cursor>"
Notice that between written text there is huge "hole" but still new characters appear at the end of string and not where cursor is.

See attached video for how this looks like. Note that there are some artifacts
due to way recording was done - the only problem is with that spacing.

When moving cursor along written lines "hole" appears at place where cursor is.

Expected results:

No "hole", no changing of width.

Additional info:

freetype-2.3.11
fontconfig-2.8.0

Not using fedora but reporting here due to "https://fedorahosted.org/liberation-fonts/" directing to this bugzilla.
Comment 1 Yanko Kaneti 2010-02-03 03:33:59 EST

*** This bug has been marked as a duplicate of bug 508899 ***

Note You need to log in before you can comment on or make changes to this bug.