This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 561318 - Liberation Mono font is not actually monospace, causing layout problems
Liberation Mono font is not actually monospace, causing layout problems
Status: CLOSED DUPLICATE of bug 508899
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-03 06:38 EST by C Sand
Modified: 2010-02-05 06:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-05 06:09:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
example of the layout problem in Gedit (16.32 KB, image/png)
2010-02-03 06:40 EST, C Sand
no flags Details
layout problem in kwrite (16.33 KB, image/png)
2010-02-03 06:42 EST, C Sand
no flags Details

  None (edit)
Description C Sand 2010-02-03 06:38:51 EST
Description of problem:

The "Liberation Mono" font is not really monospace. This causes layout problems in text editors (e.g. when editing source code).

I have experienced this with size 9 (haven't tried other sizes), on three editors: gedit, kwrite and kate.

Given that gedit and kwrite are using two different toolkits (GTK+ and Qt), it would appear that the bug is either in the font itself, or somewhere in the X server.


Version-Release number of selected component (if applicable):
Fedora 12 + updates as of 29 January 2009.


How reproducible:
Always.


Steps to Reproduce:
1. Open an editor like gedit.
2. Change font to Liberation Mono 9.
3. Type in several columns of numbers, with spacing between the columns.

Actual results:
Text columns do not line up cleanly.

Expected results:
Text columns line up cleanly.


Additional info:
I'll attach a few example screengrabs (as followups to this bug report) which show the problem.
Comment 1 C Sand 2010-02-03 06:40:59 EST
Created attachment 388510 [details]
example of the layout problem in Gedit

shows the layout problem in Gedit.
Selected font is Liberation Mono 9.
Comment 2 C Sand 2010-02-03 06:42:00 EST
Created attachment 388511 [details]
layout problem in kwrite
Comment 3 Yanko Kaneti 2010-02-05 06:09:37 EST

*** This bug has been marked as a duplicate of bug 508899 ***

Note You need to log in before you can comment on or make changes to this bug.