Bug 56142 - lang.sh does not export LC_PAPER
lang.sh does not export LC_PAPER
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 04:27 EST by Jungshik Shin
Modified: 2014-03-16 22:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-11 12:33:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jungshik Shin 2001-11-13 04:27:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
lang.sh and lang.csh in /etc/profile.d
don't export LC_PAPER. LC_PAPER IS used
by programs like psutils (see bug 48831).
Setting it in ~/.i18n does NOT have
any effect because it's not exported
by lang.sh and lang.csh. 

Version-Release number of selected component (if applicable):
 : it's not fixed as of 6.40.2-1 (in Rawhide)

How reproducible:
Always

Steps to Reproduce:
1.Add the following line to ~/.i18n
  (Germans living in the US may want to have
   this setting because in the US 
   A4 paper is hard to come by while
   US letter is commonly used.)
  LC_PAPER=en_US
  LANG=de
2.launch a new shell
3.run psnup or other programs from psutils
4. examine the output ps file to see
  which paper (US letter or a4) is used.
5. replace the line in step 1 in ~/.i18n
   by the following
   LC_PAPER=de
6. launch a new shell
7. repeat step 3 and 4 
	

Actual Results:  In both cases(step 4 and step 7), A4 paper is used by
psutils because LC_PAPER is not exported
whereas LANG is exported. When LANG
is defined but  LC_PAPER is not, 
the value of LANG determines LC_PAPER
as well. 

Expected Results:  In step 4, US letter should be used
(because LC_PAPER=en_US overrides LANG=de).
On the other hand, A4 should be used
(because now LC_PAPER is set to de).

Additional info:

In addition to LC_PAPER,
other LC_* variables (which are not currently
exported by lang.sh/lang.csh) may as well
be exported. (LC_MEASUREMENT, LC_TELEPHONE,
LC_NAME, LC_ADDRESS)
In the future, some other
programs may make use of them although
they're not used by any program at
the moment.
Comment 1 Pekka Savola 2002-04-11 12:33:06 EDT
This also happens with the latest RHL beta.
Comment 2 Bill Nottingham 2002-04-12 16:06:30 EDT
Fixed in 6.63-1.

Note You need to log in before you can comment on or make changes to this bug.