Bug 56143 - "Keep panel below other windows" doesn't work
"Keep panel below other windows" doesn't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 06:22 EST by Toralf
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-26 09:37:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2001-11-13 06:22:44 EST
Description of Problem:
GNOME control center setting "Keep panel below other windows" does not
work; it appears to have the same effect as "Keep panel on the same level
as other windows."

Version-Release number of selected component (if applicable):
1.4.0.4-38

How Reproducible:
Every time


Steps to Reproduce:
1. Open "Miscellaneous" page of panel config (Settings->Desktop->Panel);
select "Keep panel below other windows", then press OK or Apply.
2. Lower some window, e.g. via "Stacking Menu" in Sawfish.
3. Move the window around...

Actual Results:
The window moves behind everything else, including the panel.

Expected Results:
The window moves behind other windows, but on top of the panel.

Additional Information:
Window manager is sawfish-1.0.1 from GNOMEhide.
Comment 1 Paul Jenner 2001-12-20 11:58:32 EST
I see the same behaviour with standard patched Red Hat 7.2 (i.e. not GNOMEhide
or other additions).  Associated packages are sawfish-0.38-11 and
gnome-core-1.4.0.4-38 (for the panel).

To reproduce (as the reporter above):

1) start the panel and a gnome terminal
2) right click panel | Panel | Global Preferences | Miscellaneous | select "Keep
panels below other windows" and choose OK
3) move the gnome-terminal over the panel
4) move the mouse focus to the panel

This should keep the gnome-terminal over the panel, but changing the focus to
the panel raises it over the gnome-terminal.
Comment 2 Telsa Gwynne 2002-01-04 04:35:56 EST
I have this happening too. It's not just sawfish. I use WindowMaker.

gnome-core-1.4.0.4-38
gnome-libs-1.2.13-16

I just realised I had been using the beta (!) on this box and upgraded.
It was not happening in the beta. It appeared on upgrading.

I played around with panel->right-click->panel->properties->level.

"above" works perfectly, which is exactly what I don't want. 
"default", "normal" (difference?) and "below" don't. They all seem
to raise the panel as soon as it receives focus. With focus-follows-mouse
and somewhat sweeping movements around the screen, this is quite a lot
of the time.

Comment 3 Havoc Pennington 2002-01-04 10:44:38 EST
The feature was disabled on purpose at the last minute before 7.2, because
Sawfish would stick the panel below the desktop and make it "disappear" if you
had your panel in "below" mode. It was too late in the release cycle to make a
larger and more dangerous fix or even disable the GUI for the setting, i.e. a
one-line least-dangerous patch was required.

Recent Sawfish at ftp://people.redhat.com/hp/gnomehide I think no longer has the
bug being worked around, but I'm not sure if the gnomehide panel has the
workaround removed yet.
Comment 4 Havoc Pennington 2002-02-26 09:37:52 EST
Need to remove the workaround.
Comment 5 Havoc Pennington 2002-03-05 14:30:56 EST
Should be fixed in 1.4.0.4-43

Note You need to log in before you can comment on or make changes to this bug.