Bug 56149 - hyperref \href not working properly for creating URL links in PDF files
hyperref \href not working properly for creating URL links in PDF files
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 08:01 EST by Dave Reed
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-13 08:03:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lab1.tex (480 bytes, patch)
2001-11-13 08:03 EST, Dave Reed
no flags Details | Diff

  None (edit)
Description Dave Reed 2001-11-13 08:01:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
executing: latex lab1 ; dvips -Ppdf lab1 -o ; ps2pdf lab1.ps
produces a pdf file with a link, but the link wants to find ".pdf"
rather than the actual URL
acroread complains that no such file can be found, but doesn't name the file

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.use attached lab1.tex file
2.latex lab1 ; dvips -Ppdf lab1 -o ; ps2pdf lab1.ps
3.xpdf lab1.pdf
	

Actual Results:  link in the pdf file exists but apparently it is not a
link to the
URL

Expected Results:  clicking on the link would open the URL

Additional info: couldn't find the attach file any more so here is the
lab1.tex file
\documentclass[11pt]{article}

\usepackage[dvips,ps2pdf]{hyperref}

\begin{document}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%


You may either type the program in from scratch or download parts.cpp
from\\
\href
{http://capital2.capital.edu/faculty/dreed/Courses/CS160/resources.html}
{http://capital2.capital.edu/faculty/dreed/Courses/CS160/resources.html}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\end{document}
Comment 1 Dave Reed 2001-11-13 08:03:32 EST
Created attachment 37362 [details]
lab1.tex
Comment 2 Tim Waugh 2001-11-13 08:15:06 EST
You cannot have \href on a line on its own.  Instead use

\href{http://...}
{http://...}

The hyperref manual doesn't show any examples that have \href on its own on a 
line, so I'll assume for the moment that it's just not intended to be used 
like that.

Thanks for the report.
Comment 3 Dave Reed 2001-11-13 08:27:47 EST
It did work on separate lines under RedHat 7.1, but obviously I can make that
change. Thanks for the help.

Note You need to log in before you can comment on or make changes to this bug.