Bug 561539 - SELinux is preventing /usr/bin/slim "unlink" access on /var/run/slim.lock.
Summary: SELinux is preventing /usr/bin/slim "unlink" access on /var/run/slim.lock.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:ad96c36291e...
: 561540 561542 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-03 21:12 UTC by Graeme Hilton
Modified: 2010-02-11 14:42 UTC (History)
2 users (show)

Fixed In Version: 3.6.32-84.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-11 14:42:39 UTC


Attachments (Terms of Use)

Description Graeme Hilton 2010-02-03 21:12:46 UTC
Summary:

SELinux is preventing /usr/bin/slim "unlink" access on /var/run/slim.lock.

Detailed Description:

SELinux denied access requested by slim. It is not expected that this access is
required by slim and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:var_run_t:s0
Target Objects                /var/run/slim.lock [ file ]
Source                        slim
Source Path                   /usr/bin/slim
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           slim-1.3.1-9.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-78.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.12-174.2.3.fc12.i686 #1 SMP
                              Mon Jan 18 20:22:46 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Wed 03 Feb 2010 09:07:42 PM GMT
Last Seen                     Wed 03 Feb 2010 09:07:42 PM GMT
Local ID                      41ce365f-5298-4a45-9bcd-674e38645f95
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1265231262.309:33): avc:  denied  { unlink } for  pid=1254 comm="slim" name="slim.lock" dev=dm-0 ino=3646 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1265231262.309:33): arch=40000003 syscall=10 success=no exit=-13 a0=839b95c a1=0 a2=a2bff4 a3=839b95c items=0 ppid=1 pid=1254 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=500 fsgid=0 tty=(none) ses=1 comm="slim" exe="/usr/bin/slim" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-78.fc12,catchall,slim,xdm_t,var_run_t,file,unlink
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t var_run_t:file unlink;

Comment 1 Miroslav Grepl 2010-02-03 22:29:46 UTC
Fixed in selinux-policy-3.6.32-82.fc12

Comment 2 Miroslav Grepl 2010-02-03 22:30:21 UTC
*** Bug 561540 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2010-02-03 22:30:38 UTC
*** Bug 561542 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2010-02-03 23:22:11 UTC
selinux-policy-3.6.32-82.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-82.fc12

Comment 5 Fedora Update System 2010-02-05 01:45:12 UTC
selinux-policy-3.6.32-84.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1492

Comment 6 Fedora Update System 2010-02-11 14:38:00 UTC
selinux-policy-3.6.32-84.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.