Bug 561618 - Publican repeats text in PDFs when using callouts in screen sections
Publican repeats text in PDFs when using callouts in screen sections
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-03 21:32 EST by Jared Smith
Modified: 2010-11-23 23:18 EST (History)
5 users (show)

See Also:
Fixed In Version: publican-1.5-0.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-26 22:30:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of resulting PDF with duplicated text. (39.15 KB, image/png)
2010-02-03 21:32 EST, Jared Smith
no flags Details

  None (edit)
Description Jared Smith 2010-02-03 21:32:57 EST
Created attachment 388690 [details]
Screenshot of resulting PDF with duplicated text.

Description of problem:

If I use a callout within my screen tags, Publican duplicates the text

Version-Release number of selected component (if applicable):

publican-1.4-1.fc12.noarch

How reproducible:

Always

Steps to Reproduce:
1. cd /tmp
2. publican create --name CalloutTest 
3. cd CalloutTest
4. Add the text below to en-US/Chapter.xml, right before the closing chapter tag:

   <section>
      <title>Callout Test</title>
      <para>This is a test of callouts within a <literal>screen</literal> tag.</para>
      <screenco>
         <areaspec>
            <area id="make" coords="2"/>
            <area id="install" coords="3"/>
         </areaspec>
<screen format="linespecific"><prompt>[root@server src]# </prompt><userinput>cd foo.<replaceable>X</replaceable>.<replaceable>Y</replaceable></userinput>
<prompt>[root@server foo.<replaceable>X</replaceable>.<replaceable>Y</replaceable>]# </prompt><userinput>make</userinput>
<prompt>[root@server foo.<replaceable>X</replaceable>.<replaceable>Y</replaceable>]# </prompt><userinput>make install</userinput></screen>
         <calloutlist>
            <callout arearefs="make">
               <para>This command compiles the <application>foo</application> source code into an program</para>
            </callout>
            <callout arearefs="install">
               <para>This command installs the <application>foo</application> application into the proper system directory</para>
            </callout>
         </calloutlist>
      </screenco>
   </section>

5. publican build --formats=pdf --langs=en-US
6. Examine the resulting PDF
  
Actual results:

Duplicated text within the screen section.  (Will attach screenshot.)

Expected results:

The text should not be duplicated.

Additional info:
Comment 1 Ruediger Landmann 2010-02-03 23:18:40 EST
I'm seeing this too, in PDF as well as HTML.
Comment 2 Jeff Fearn 2010-02-14 19:15:39 EST
FYI this is caused by the tagging of the content in the screen, prompt etc, it will take some time to fix as I'm pushed for time ATM.

Cheers, Jeff.
Comment 3 Jeff Fearn 2010-02-20 23:01:16 EST
Re-factored insertCallouts to handle nested tags.
Comment 4 Fedora Update System 2010-02-26 00:24:38 EST
publican-1.5-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc12
Comment 5 Fedora Update System 2010-02-26 00:28:17 EST
publican-1.5-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc13
Comment 6 Fedora Update System 2010-02-26 00:28:24 EST
publican-1.5-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc11
Comment 7 Fedora Update System 2010-02-26 00:28:36 EST
publican-1.5-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc12
Comment 8 Fedora Update System 2010-02-26 00:30:57 EST
publican-1.5-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc13
Comment 9 Fedora Update System 2010-02-26 00:34:58 EST
publican-1.5-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc11
Comment 10 Fedora Update System 2010-02-26 22:29:19 EST
publican-1.5-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2010-02-26 22:45:08 EST
publican-1.5-0.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.