Bug 561764 - SELinux is preventing /usr/bin/qemu-system-x86_64 "write" access on sr0.
SELinux is preventing /usr/bin/qemu-system-x86_64 "write" access on sr0.
Status: CLOSED DUPLICATE of bug 536760
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:58da08a7b23...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-04 03:53 EST by Ingimar Jonsson
Modified: 2010-02-04 08:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-04 08:48:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ingimar Jonsson 2010-02-04 03:53:52 EST
Summary:

SELinux is preventing /usr/bin/qemu-system-x86_64 "write" access on sr0.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by qemu-system-x86. It is not expected that this
access is required by qemu-system-x86 and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:svirt_t:s0:c13,c411
Target Context                system_u:object_r:virt_content_t:s0
Target Objects                sr0 [ blk_file ]
Source                        qemu-system-x86
Source Path                   /usr/bin/qemu-system-x86_64
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           qemu-system-x86-0.12.2-4.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-78.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.7-41.fc12.x86_64 #1
                              SMP Wed Feb 3 21:08:10 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    fim  4.feb 2010, 08:52:09 GMT
Last Seen                     fim  4.feb 2010, 08:52:09 GMT
Local ID                      66d3bb3f-adf3-4b29-8d99-5e2e48952dde
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1265273529.818:30138): avc:  denied  { write } for  pid=4362 comm="qemu-system-x86" name="sr0" dev=devtmpfs ino=4232 scontext=system_u:system_r:svirt_t:s0:c13,c411 tcontext=system_u:object_r:virt_content_t:s0 tclass=blk_file

node=(removed) type=SYSCALL msg=audit(1265273529.818:30138): arch=c000003e syscall=2 success=no exit=-30 a0=21b07e0 a1=81002 a2=0 a3=0 items=0 ppid=1 pid=4362 auid=4294967295 uid=107 gid=107 euid=107 suid=107 fsuid=107 egid=107 sgid=107 fsgid=107 tty=(none) ses=4294967295 comm="qemu-system-x86" exe="/usr/bin/qemu-system-x86_64" subj=system_u:system_r:svirt_t:s0:c13,c411 key=(null)



Hash String generated from  selinux-policy-3.6.32-78.fc12,catchall,qemu-system-x86,svirt_t,virt_content_t,blk_file,write
audit2allow suggests:

#============= svirt_t ==============
allow svirt_t virt_content_t:blk_file write;
Comment 1 Ingimar Jonsson 2010-02-04 03:58:02 EST
I was running Virtual Machine Manager 0.8.2 and creating a new virtual machine.
Using Local install media
Everything was default settings, installing winXP 
The error comes as soon as the VM starts.
Comment 2 Daniel Walsh 2010-02-04 08:48:14 EST

*** This bug has been marked as a duplicate of bug 536760 ***

Note You need to log in before you can comment on or make changes to this bug.