Bug 561809 - [abrt] crash in xterm-253-1.fc12
[abrt] crash in xterm-253-1.fc12
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
abrt_hash:e689c9dfc0657c10c579993f0cf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-04 07:00 EST by matti aarnio
Modified: 2010-07-26 05:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-26 05:39:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (5.89 KB, text/plain)
2010-02-04 07:00 EST, matti aarnio
no flags Details

  None (edit)
Description matti aarnio 2010-02-04 07:00:01 EST
abrt 1.0.4 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/xterm
component: xterm
executable: /usr/bin/xterm
kernel: 2.6.31.12-174.2.3.fc12.x86_64
package: xterm-253-1.fc12
rating: 4
reason: Process was terminated by signal 6 (Aborted)
release: Fedora release 12 (Constantine)

comment
-----
See above.

This probably does not happen, if xterm starts to UTF8 mode.  Just necessitating mode change causes crash.

How to reproduce
-----
1. Start xterm in non-UTF8 mode
2. output some UTF-8 characters on terminal, observe that they are line noise
3. turn on UTF-8 from control-Right-button menu
4. use program that causes terminal to flip on alternate screen (like "nano" editor)
5. exit that program -> xterm crashes
Comment 1 matti aarnio 2010-02-04 07:00:04 EST
Created attachment 388770 [details]
File: backtrace
Comment 2 Thomas E. Dickey 2010-02-04 20:46:02 EST
It might be data-dependent, or resource-dependent.
The resource-settings would help, particularly if
it's easy for you to reproduce (making data less likely).

(a quick check here doesn't break xterm #255,
and I don't see that I'd touched this area).

I'll check the backtrace and see if I can find the bug...
Comment 3 Thomas E. Dickey 2010-03-17 05:23:34 EDT
I was unable to trigger this bug, but it sounds like the same case
as this:

    Patch #255 - 2010/1/21
          + correct  logic  used  to  switch  to  alternate  screen using
            FIFO-lines configuration (Debian #565772).
Comment 4 Miroslav Lichvar 2010-03-17 06:50:19 EDT
Can you please verify the problem is fixed in xterm-256? (available in updates)
Comment 5 matti aarnio 2010-03-17 09:59:49 EDT
My quick test shows UTF-8 being used everywhere even when I try to command other modes, which may mask the issue.

Anyway closing the pico editor inside this xterm does not cause the xterm to crash anymore.
Comment 6 matti aarnio 2010-07-26 05:39:04 EDT
The problem has not re-appeared.

Note You need to log in before you can comment on or make changes to this bug.