Bug 56189 - %GNUconfigure macro broken
%GNUconfigure macro broken
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 14:03 EST by Enrico Scholz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-13 14:03:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-11-13 14:03:14 EST
Description of Problem:

The %GNUconfigure macro is broken in several aspects:
- it does not set CXXFLAGS
- it sets LDFLAGS to an empty string; with recent autotools
(autoconf-2.52-3, automake-1.5-1) it fails to detect the C++ compiler,
because it tries to execute "g++ '' conftest.cc" in a autoconf-test. There
'' is the value of $LDFLAGS and g++ won't find this file.
- adding additional flags to ./configure is not intuitive (you have to
execute %{GNUconfigure -- --extra-flags=...}). A solution could be a
definition of %GNUconfigure as a sh-function and calling this at the end:

| % define GNUconfigure(MCs:)
|   function __rpm_gnuconfigure {
|      ... body ...
|      ./configure ... "$@"
|      ...
|   }; __rpm_gnuconfigure

- the filename "configure.in" (used in some tests) is deprecated in recent
autotools; configure.ac is recommended now

- the whole libtoolize/autoheader/aclocal/autoconf stuff can be replaced by
a simple "autoreconf -i"


Version-Release number of selected component (if applicable):

rpm-4.0.3-1.04
Comment 1 Jeff Johnson 2001-11-15 18:42:01 EST
Nod. Meanwhile, %GNUconfigure is hardly used, and not worth the
effort of fixing. Don't use it is the message.

Note You need to log in before you can comment on or make changes to this bug.