Bug 561939 - Calibre fails to start after install
Summary: Calibre fails to start after install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: calibre
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ionuț Arțăriși
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 567030 568265 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-04 18:07 UTC by Peter Hedlund
Modified: 2010-03-03 01:51 UTC (History)
3 users (show)

Fixed In Version: calibre-0.6.42-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-03 01:51:34 UTC
Type: ---


Attachments (Terms of Use)

Description Peter Hedlund 2010-02-04 18:07:03 UTC
Description of problem: Calibre fails to start


Version-Release number of selected component (if applicable): 0.6.36-1


How reproducible: Always


Steps to Reproduce:
1. sudo yum install calibre
2. calibre &
3.
  
Actual results: 

Traceback (most recent call last):
  File "/usr/bin/calibre", line 19, in <module>
    sys.exit(main())
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 118, in main
    app, opts, args, actions = init_qt(args)
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 34, in init_qt
    from calibre.gui2.ui import Main
  File "/usr/lib64/calibre/calibre/gui2/ui.py", line 38, in <module>
    from calibre.gui2.widgets import ProgressIndicator, IMAGE_EXTENSIONS
  File "/usr/lib64/calibre/calibre/gui2/widgets.py", line 25, in <module>
    from calibre.gui2.progress_indicator import ProgressIndicator as _ProgressIndicator
  File "/usr/lib64/calibre/calibre/gui2/progress_indicator/__init__.py", line 14, in <module>
    pi_error)
RuntimeError: Failed to load the Progress Indicator plugin: the sip module implements API v7.0 but the progress_indicator module requires API v6.0



Expected results: A GUI


Additional info:

Comment 1 Peter Hedlund 2010-02-04 22:48:43 UTC
I downloaded 0.6.37 from koji and the problem persists.

Comment 2 Ionuț Arțăriși 2010-02-07 12:26:58 UTC
Hi, Peter

What version of sip do you have installed? Is it in the fedora repositories?

Comment 3 Peter Hedlund 2010-02-08 23:03:47 UTC
sip-4.10-1.fc12.x86_64
(http://koji.fedoraproject.org/koji/packageinfo?packageID=208)

I upgraded sip after the initial failure to start calibre, but without success. I then rebuilt the calibre rpm and was able to get a functional install of calibre.

Calibre clearly depends on what version of sip it was compiled against and changing this can break calibre.

Comment 4 Ionuț Arțăriși 2010-02-25 10:22:44 UTC
*** Bug 568265 has been marked as a duplicate of this bug. ***

Comment 5 Ionuț Arțăriși 2010-02-25 10:24:25 UTC
*** Bug 567030 has been marked as a duplicate of this bug. ***

Comment 6 Ionuț Arțăriși 2010-02-26 22:34:41 UTC
I believe that this bug was caused by a qt version >=4.6 . As the newer versions of all the packages that use qt 4.6 including pyqt4 and sip are now in fedora 12, I've updated the calibre package.

qt 4.6 was also a requirement for any calibre >= 0.6.38.

It would be great if you could test this bug and give some feedback in bodhi at updates.fedoraproject.org

Comment 7 Fedora Update System 2010-02-26 22:37:51 UTC
calibre-0.6.42-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/calibre-0.6.42-1.fc12

Comment 8 Peter Hedlund 2010-02-28 23:53:26 UTC
(In reply to comment #7)
> calibre-0.6.42-1.fc12 has been submitted as an update for Fedora 12.
> http://admin.fedoraproject.org/updates/calibre-0.6.42-1.fc12    

This version appears to be working fine. Thank you.

Comment 9 Fedora Update System 2010-03-02 00:53:32 UTC
calibre-0.6.42-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update calibre'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-3212

Comment 10 Fedora Update System 2010-03-03 01:51:24 UTC
calibre-0.6.42-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.