Bug 56195 - XFree86-4.1.0-6 loses keyboard for G200
XFree86-4.1.0-6 loses keyboard for G200
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 15:08 EST by Sammy
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-16 09:09:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2001-11-13 15:08:37 EST
Upgrading from 4.1.0-3 to 4.1.0-6 resulted in a non
functioning keyboard.

The graphics card MGA G200

Reverting back to 4.1.0-3 solves the problem
Comment 1 Mike A. Harris 2001-11-15 00:18:30 EST
Works for me, and every other user that is using 4.1.0-6.  There
have been no changes in any codepaths that could cause the keyboard
to stop working since 4.1.0-3.

I would need a lot more information from you about your setup, to be
able to consider this a bug rather than just a local misconfiguration.

4.1.0-6 won't give any useful fixes over 4.1.0-3 for your hardware
anyways though, as there haven't been any MGA changes.

Usually, when the keyboard/mouse don't work in XFree86, it is a
misconfigured ps2 mouse, which locks up the keyboard controller.

Any additional info?
Comment 2 Sammy 2001-11-15 11:09:53 EST
Well, may be it is something else but all of the 3 computers I have running
at the same level (Rawhide Nov.12) showed the same symptom and I had
to go back to -3. I did not change anything in config files for X or hardware.
For example, all machines frequently lost keyboard at various stages. More
frequently at kdm login level, or immediately after login, or after leaving the
machine with xlock and coming back later to login. The MGA machine was the
most severe of all. KDE has been at 2.2.1 level for a while. One thing common
in all is the use of kdm/kde. I don't have any more info since when the system
hung up I had to kill all processes from another terminal to get back in. The
funny thing though is that it is not happening with 4.1.0-3.
Comment 3 Sammy 2001-11-16 09:09:14 EST
OK. I was wrong! The same thing is happening with 4.1.0-3 as well, which
did not happen earlier. The main problem is with kdm and xlock. If one
leaves them for a long time they no longer accept keyboard input. Mouse works
fine so for kdm one can restart X and then it is ok. For xlock I have to restart
X from another terminal. The packages I upgraded are:

binutils-2.11.92.0.7-2
dev-3.2-6.i386.rpm
diffutils-2.7.2-3
e2fsprogs-1.25-1
fileutils-4.1.1-1 (recompiled rpm since there was a bug in rawhide version)
freetype-2.0.5-1
gdb-5.0.92-1
grep-2.5-0.f.3
htdig-3.2.0-1.b4.0.72
lockdev-1.0.0-15
libxml2-2.4.10-1
libxml-1.8.16-3
sh-utils-2.0.11-7
SysVinit-2.79-2
usermode-1.46-1
pam-0.75-19

Any suspects here?

Comment 4 Mike A. Harris 2002-03-12 07:59:50 EST
The current release of 4.1.0 is 4.1.0-15 officially, and on a clean system
with all erratum applied the keyboard works fine.  The keyboard driver is
independant of the video driver so G200 should be irrelevant.

Rawhide is a horrible mess of 3 week old crap at this point so I highly
recommend not using anything from it at all.  Our current codebase is much
different.  Why rawhide is this horribly broken and out of date is anyone's
guess.

If you want updated packages to replace, use the ones on my ftp space on
people.redhat.com instead.  That code is actually tested, and not randomly
broken like rawhide has been for over a month.

I'm told rawhide will be fixed soon, but I dont want to rely on that.  Try
4.2.0-6.44 or higher instead.

Note You need to log in before you can comment on or make changes to this bug.