This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 56198 - uunhandled exception, installer fails
uunhandled exception, installer fails
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 15:35 EST by Joe Theriault
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-24 21:05:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
this is dump attachment for bug 56198 (70.92 KB, text/plain)
2001-12-04 11:38 EST, Joe Theriault
no flags Details
my anaconda dump with "RuntimeError: /usr/sbin/usermod can not be run" (772.90 KB, text/plain)
2001-12-07 22:57 EST, Need Real Name
no flags Details
more detailed log of the problem & findings (3.45 KB, text/plain)
2001-12-08 11:33 EST, Need Real Name
no flags Details
another anacdump.txt from 3rd attempt (757.58 KB, text/plain)
2001-12-08 11:35 EST, Need Real Name
no flags Details
ls -l /usr/lib from failed install, to show missing libslang.so.1 (133.90 KB, text/plain)
2001-12-08 11:36 EST, Need Real Name
no flags Details
ls -AlR of the root partition after failed install (809.80 KB, application/octet-stream)
2001-12-08 13:49 EST, Need Real Name
no flags Details
list of files in the 'install' root and /mnt/runtime after faied install (103.25 KB, text/plain)
2001-12-09 16:12 EST, Need Real Name
no flags Details

  None (edit)
Description Joe Theriault 2001-11-13 15:35:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; SunOS 5.6 sun4u)

Description of problem:
tryed the basic workstation install from installer, grub, and gnome 
I have included the write to floppy file from the installer

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Tryed reinstalling 7.2 several times
2. Three times I received unhandled exception. I finally wrote file out to
floppy
3. The other times I did not get the unhandled exception, the final reboot
failed after getting successful installation.
	

Additional info:

Hardware specs..
Intel d815eeaal mthbrd, 
PIII, 733, 256 cache, 133fsb, FCPGA processor
Riva tnt-2 AGP video card
Dell 1710 17" monitor
40 gig IDE H.D.  
384 MB memory
plextor px-w1610a/sw cd-rw drive
3.25 floppy
Comment 1 Jeremy Katz 2001-11-13 15:59:34 EST
Could you attach the dump of the exception that you recieve?
Comment 2 Joe Theriault 2001-11-21 13:46:59 EST
I  have submitted the dump and was wondering if any progress has been made. I
see this bug is still listed as needing info.. Let me know I am really waiting
for a result so i can install this ver on my computer...
Comment 3 Peter Lee 2001-11-26 01:04:16 EST
I also have the same problem...please help
Comment 4 Joe Theriault 2001-11-28 15:49:52 EST
	It has been 2wks since original bug submission. I have heard nothing. Is anyone
trying to reslove this problem? I hope to get some response. Please help.
Comment 5 Michael Fulbright 2001-12-03 17:10:21 EST
I do not see any attachments to this bug - please try to attach the exception again.
Comment 6 Joe Theriault 2001-12-04 11:38:24 EST
Created attachment 39588 [details]
this is dump attachment for bug 56198
Comment 7 Need Real Name 2001-12-07 22:53:07 EST
I get a very similar error, except in my case /usr/sbin/usrmod can't be run. In addition
there is one thing that does not appear on the anaconda log: a message pops up
shortly after the last package is loaded which says something like 'can't load libslang.so.1'.
I don't know the exact error, because it gets overwritten, but I am sure about the filename.
Will attach dump and hopefully more detail about the error message if I get it.
Comment 8 Need Real Name 2001-12-07 22:57:06 EST
Created attachment 40087 [details]
my anaconda dump with "RuntimeError: /usr/sbin/usermod can not be run"
Comment 9 Need Real Name 2001-12-08 11:25:19 EST
I know why my install keeps failing, but I don't know how to fix it.
anaconda fails because it can't run /usr/sbin/usermod, because
/usr/lib/libslang.so.1 can't be loaded,  because it isn't there.

I have three attachments from my latest attempt: problog.txt , the detailed account;
anacdump2.txt, the latest anaconda dump; and usrlib.txt which is an ls -l of the
/usr/lib directory.
Comment 10 Need Real Name 2001-12-08 11:33:20 EST
Created attachment 40107 [details]
more detailed log of the problem & findings
Comment 11 Need Real Name 2001-12-08 11:35:10 EST
Created attachment 40108 [details]
another anacdump.txt from 3rd attempt
Comment 12 Need Real Name 2001-12-08 11:36:39 EST
Created attachment 40109 [details]
ls -l /usr/lib from failed install, to show missing libslang.so.1
Comment 13 Need Real Name 2001-12-08 13:45:26 EST
On closer examination I find that there isn't a /usr/sbin/usermod on the disk either, and I guess maybe it runs off the ramdisk or something. So maybe libslang.so.1 is 
supposed to load from the ramdisk. There is a /usr/sbin/kudzu which contains the string ' libslang.so.1'.
I'm going to stop for now; I'm also providing a ls -AlR of the whole install.
Comment 14 Need Real Name 2001-12-08 13:49:29 EST
Created attachment 40127 [details]
ls -AlR of the root partition after failed install
Comment 15 Need Real Name 2001-12-09 16:10:27 EST
OK. have some more info. Now it looks like anaconda
can't run '/usr/sbin/usermod' because there is no 'usermod'
anywhere on the system, even within the 'install' root.
Also, there is no 'chfn' in /usr/sbin or anywhere else
- this is the command which fails for jtheriault@ll.mit.edu

Actually there is /mnt/sysimage/usr/share/doc/nss_ldap-172/pam.d/chfn
but that is not executable.


Attachment INSROOT.TXT is a ls -lA of the 'install' root
and ls -lRA of the following subdirectories:

/dev 
/etc
/mnt/runtime
/modules
/proc
/sbin
/tmp
/var

This info was obtained by going into 'debug' after the failed
install, and getting a shell by running "os.system('sh')"
An 'ls -lAR' of what is '/mnt/sysimage' was previously provided
as attachment 40127 [details].

There is a '/usr/lib/libslang.so.1'  which is
really /mnt/runtime/usr/libslang.so.1
However, there is no /usr/sbin/usermod in this
environment or any 'usermod' file that I can find
anywhere.


Comment 16 Need Real Name 2001-12-09 16:12:10 EST
Created attachment 40227 [details]
list of files in the 'install' root and /mnt/runtime after faied install
Comment 17 Need Real Name 2001-12-09 22:02:41 EST
I tried the install using 'boot.img' floppy,  from a set of .iso files contained on
a hard disk (rather than the FTP install done previously) and it worked
fine this time. So I'm OK now. I have kept one of the failed installs on
a partition in case there is anything that might be useful to you there.
Comment 18 Peter Chokola 2001-12-24 21:05:47 EST
I get the same error as the anacdump.txt file dated 12-04-2001 all the way up 
to the error at line 208.  After that I get
File "/tmp/updates/packages.py". line 793, in doPostinstallf.close()
IOError: [Errno: 28] no space left on device.

I can not dump the file because at that point my floppy drive fails.  Is there 
a special way to dump it to the floppy, ie I need a formatted disk or something?

If I load the workstation version it works.  If I do custom and select 
everything, I get the error.  I let the Red Hat software partition my drive and 
the drive is 36GBytes.  I just purchased Red Hat and this is my first load.
Comment 19 Michael Fulbright 2002-01-15 16:52:37 EST
The error occurs because of a bad CD. By using the hard drive install you got
around the issue.
Comment 20 Need Real Name 2002-01-15 23:46:21 EST
There was no CD involved. Install was from FTP image derived from downloaded ISO image (and MD5 checksum was OK). There may have been a problem with 
W32-based FTP server. The hard drive install , which worked, was from the same ISO images used to build the FTP directory from which the failed install occurred.

Note You need to log in before you can comment on or make changes to this bug.