Bug 562033 - Modification of packages for SELinux support shouldn't be necessary.
Modification of packages for SELinux support shouldn't be necessary.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libselinux (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-04 22:14 EST by JW
Modified: 2010-02-05 10:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-05 10:21:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2010-02-04 22:14:43 EST
Description of problem:
See summary.

Version-Release number of selected component (if applicable):
libselinux-2.0.87-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -qi libselinux

Actual results:
1. ....

Expected results:
1. package libselinux is not installed

Additional info:
It should never have been necessary to modify any applications to support SELinux.  It should only exist in the kernel (with associated control interfaces and programs), and hooked into something dynamically loaded into every application if necessary (eg like linux-gate.so).
Comment 1 Daniel Walsh 2010-02-05 10:21:02 EST
We are not going to do this.

Note You need to log in before you can comment on or make changes to this bug.