This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 562037 - cpu performance is not improved with advanced cpu flag
cpu performance is not improved with advanced cpu flag
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: john cooper
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-02-04 22:48 EST by Suqin Huang
Modified: 2014-07-24 23:45 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 14:51:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
cpu benchmark test result (15.24 KB, application/vnd.oasis.opendocument.spreadsheet)
2010-02-04 22:48 EST, Suqin Huang
no flags Details
sandra muti-media test report (1.80 KB, text/plain)
2010-02-04 23:57 EST, Suqin Huang
no flags Details
have some improvement (1.79 KB, text/plain)
2010-11-26 05:43 EST, Suqin Huang
no flags Details
without sse4.1, sse4.2 (1.79 KB, text/plain)
2010-11-26 05:44 EST, Suqin Huang
no flags Details

  None (edit)
Description Suqin Huang 2010-02-04 22:48:16 EST
Created attachment 388956 [details]
cpu benchmark test result

Description of problem:
According to https://bugzilla.redhat.com/show_bug.cgi?id=518090#c29, create this bug to trace vm cpu performance.

Version-Release number of selected component (if applicable):
kvm-83-155.el5

How reproducible:


Steps to Reproduce:
1. Boot guest with the following cpu para to compare their performance.
Intel:
-cpu qemu64,+sse2,+ssse3,+sse4_1,+sse4_2,+popcnt 
-cpu qemu64,+sse2,+ssse3

AMD:
-cpu qemu64,+sse2,+cx16,+sse4a,+misalignsse,+popcnt,+abm
-cpu qemu64,+sse2,+cx16, RDTSCP 

RHEL system: 
run phoronix-test-suite, cpu test suite, java test suite, encoding test suite
There is no obvious improvement with and without sse4.2 on vm.
The test cases result of physical box testing show that with sse4.2 is much more batter than without sse4.2.

Windows:
x264: fewer improvement with sse4.2, have some improvement with sse4a.

sandra muti-media: no obvious improvement with sse4.2, but the result report
show that sse4.1 instruction is used.

Details please refer to the attachment.


2.
3.
  
Actual results:


Expected results:


Additional info:
Intel: 

host:
flags	: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx rdtscp lm constant_tsc ida nonstop_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr sse4_1 sse4_2 popcnt lahf_lm

processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 26
model name	: Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz


AMD:
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc nonstop_tsc pni cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy altmovcr8 abm sse4a misalignsse 3dnowprefetch osvw

processor	: 3
vendor_id	: AuthenticAMD
cpu family	: 16
model		: 2
model name	: Quad-Core AMD Opteron(tm) Processor 1352
Comment 1 Suqin Huang 2010-02-04 23:57:29 EST
Created attachment 388967 [details]
sandra muti-media test report
Comment 2 Suqin Huang 2010-02-05 00:07:59 EST
Mark,
Do you have any suggestion for the performance benchmark testing.

Dor,
Do you have any suggestion for the testing result?
Comment 3 Dor Laor 2010-02-09 04:41:25 EST
The differences on physical machines might be bigger since it is not only the flags that were changed. Can you post the /proc/cpuinfo of the guest? Since sandra sees sse4_2 it does work, not sure if it is a real bug.

Maybe there is a sse4_2 unit test that can provide better results?
Comment 5 john cooper 2010-02-10 11:03:37 EST
(In reply to comment #3)
> The differences on physical machines might be bigger since it is not only the
> flags that were changed. Can you post the /proc/cpuinfo of the guest?

Please include an "x86info -a -f" dump in addition to /proc/cpuinfo
as reading the raw cpuid data is the best confirmation of the flag
state.

> Since sandra sees sse4_2 it does work, not sure if it is a real bug.

Yea, seems to be.  Just to validate that assumption how does the
Sandra Benchmark react if an sse4.2 instruction isn't discovered?
Might be useful to attach a log of that scenario here for reference.
Comment 6 Suqin Huang 2010-02-21 04:10:59 EST
sandra benchmark is tested on windows, can not cat "x86info -a -f" info.
get cpu flag with CPUID: sse sse2 sse3 ssse3 sse4.1 sse4.2 VT
Comment 10 Yaniv Kaul 2010-03-08 04:23:48 EST
(In reply to comment #6)
> sandra benchmark is tested on windows, can not cat "x86info -a -f" info.
> get cpu flag with CPUID: sse sse2 sse3 ssse3 sse4.1 sse4.2 VT    

So using the exact command line, just boot it from a Live CD with Linux.
I'm pretty sure for start the flags won't change.
Comment 12 john cooper 2010-03-08 13:16:28 EST
[Forgot to set the "need additional info" request in previous comment.]
Comment 19 Suqin Huang 2010-11-26 05:41:58 EST
1. host:
kernel:
2.6.18-232.el5

kvm:
kvm-83-215.el5

cpu:

processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 26
model name	: Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz

flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx rdtscp lm constant_tsc ida nonstop_tsc pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr sse4_1 sse4_2 popcnt lahf_lm

2. guest
window2008r2

Sandra:
http://download1us.softpedia.com/dl/bd9271c3262ac3049ef0134f3f538b57/4cee0a6d/100005280/software/system/info/san1720.exe

3. x86info 

boot with sse4.1,sse4.2
x87info v1.21.  Dave Jones 2001-2007
Feedback to <davej@redhat.com>.

Found 2 CPUs
--------------------------------------------------------------------------
CPU #1
Family: 6 Model: 6 Stepping: 3 Type: 0 Brand: 0
CPU Model: Celeron / Mobile Pentium II Original OEM
Feature flags:
 fpu de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflsh mmx fxsr sse sse2
Extended feature flags:
 sse3 [19] [20] [31]
 [0] [2] [3] [4] [5] [6] [7] [8] [9] SYSCALL [13] [15] [16] xd [23] [24] em64t
Cache info
 L1 Instruction cache: 32KB, 8-way associative. 64 byte line size.
 L1 Data cache: 32KB, 8-way associative. 64 byte line size.
 L2 unified cache: 2MB, sectored, 8-way associative. 64 byte line size.
TLB info
--------------------------------------------------------------------------
CPU #2
Family: 6 Model: 6 Stepping: 3 Type: 0 Brand: 0
CPU Model: Celeron / Mobile Pentium II Original OEM
Feature flags:
 fpu de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflsh mmx fxsr sse sse2
Extended feature flags:
 sse3 [19] [20] [31]
 [0] [2] [3] [4] [5] [6] [7] [8] [9] SYSCALL [13] [15] [16] xd [23] [24] em64t
Cache info
 L1 Instruction cache: 32KB, 8-way associative. 64 byte line size.
 L1 Data cache: 32KB, 8-way associative. 64 byte line size.
 L2 unified cache: 2MB, sectored, 8-way associative. 64 byte line size.
TLB info
--------------------------------------------------------------------------
WARNING: Detected SMP, but unable to access cpuid driver.
Used Uniprocessor CPU routines. Results inaccurate.
Comment 20 Suqin Huang 2010-11-26 05:43:30 EST
Created attachment 463057 [details]
have some improvement
Comment 21 Suqin Huang 2010-11-26 05:44:15 EST
Created attachment 463058 [details]
without sse4.1, sse4.2
Comment 24 RHEL Product and Program Management 2011-01-11 15:37:22 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 25 RHEL Product and Program Management 2011-01-11 17:49:30 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 26 john cooper 2011-01-13 14:51:50 EST
Looks like a benchmark issue citing comment/attachements #20/#21
above which indicate a ~50% improvement in the case of +sse4_1,+sse4_2.

Note You need to log in before you can comment on or make changes to this bug.