Bug 56220 - 2.4.9-13 memory usage explodes and uses swap until most memory is consumed.
2.4.9-13 memory usage explodes and uses swap until most memory is consumed.
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-13 19:02 EST by Jim Wray
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 16:46:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a screenshot of top (159.63 KB, image/jpeg)
2001-11-15 13:57 EST, Jim Wray
no flags Details

  None (edit)
Description Jim Wray 2001-11-13 19:02:58 EST
Description of Problem:

After very little usage, (i.e. a couple of days) System can become unusable
due to memory problems. (Problem with Riel VM?)  We have two machines with
RH 7.2 on them.  Both of these have the latest update, but show symptoms
with 2.4.9-7 also. (Never tested with 2.4.7-10)  Our other machines with
the exact same configuration, except using RH 7.1 with 2.4.3-12 kernel do
not display this problem.  These machines are PIII 800's with 512 RAM and
1024 swap.   Typical usage includes emacs, galeon/mozilla, and gcc.  My
tool used to glean memory information is xosview.  However, system slowdown
and harddrive thrashing are evidence of the problem even if xosview is wrong.  

I may compile 2.4.15 when it comes out and see if the problem persists, and
post an update. 

Version-Release number of selected component (if applicable):
2.4.9-13

How Reproducible:
every time

Steps to Reproduce:
1.  boot up.
2.  use computer for 1-3 days
3.  notice slowdown and memory problems (heavy swap usage)

Actual Results:
computer slowed to barely usable state.  swap memory nearly used up. (at
500M usage right now)

Expected Results:
swap memory should not be used up without being freed.  I never ran
programs that should have entered swap anyway, not with 512 MB of RAM anyway.  

Additional Information:
Comment 1 Arjan van de Ven 2001-11-15 10:37:52 EST
can you use "top" and then the "M" key to see if there's no accidental userspace
memory leak ?
(M sorts by memory usage)
Comment 2 Jim Wray 2001-11-15 13:57:09 EST
Created attachment 37622 [details]
a screenshot of top
Comment 3 Jim Wray 2001-11-15 14:05:23 EST
I have attached a screenshot of top.  It looks like it is a memory leak of some
sort.  Upon launch, galeon spawns 5 galeon-bin processes each taking 9% or 46M
of memory.  Additionally, I guess when I went to a certain page, 17 java_vm
processes were launched, each taking 5% or 25M of memory.  This constitutes 655M
of memory usage!  While this much memory use is appalling, when closing the
applications down, the swap and memory usage still remains high, meaning there
must be a memory leak of some sort.  I know you don't distribute the jdk, and I
am using galeon 12.7, so this is certainly not RH's responsibility, but, it
looks like the mozilla, folks and galeon people need to work on this issue
pretty badly.  

Thanks for your help, and any suggestions you might still have.  But, I would
have to say that although I didn't experience the grind down problems in 7.1,
this probably isn't a kernel issue as much as memory issue with either mozilla's
rendering engine used in galeon, or galeon itself coupled with how many
java_vm's are launched each using 25M of memory. ouch!

Thanks.

Note You need to log in before you can comment on or make changes to this bug.