Bug 562255 - Storm of EDID probe notifications ties up Xorg+udev, slows machine to a crawl
Storm of EDID probe notifications ties up Xorg+udev, slows machine to a crawl
Status: CLOSED DUPLICATE of bug 523646
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-05 13:34 EST by Alex Villacís Lasso
Modified: 2010-02-17 10:53 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-17 10:53:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
PCI description of machine as reported by lspci (23.05 KB, text/plain)
2010-02-05 13:34 EST, Alex Villacís Lasso
no flags Details
dmesg output on affected kernel (38.41 KB, text/plain)
2010-02-05 13:35 EST, Alex Villacís Lasso
no flags Details
Copy of /dev/.udev/queue.bin during probe storm (19.39 KB, application/x-bzip)
2010-02-05 13:37 EST, Alex Villacís Lasso
no flags Details
Xorg log during episode of probe storm (65.40 KB, application/x-bzip)
2010-02-05 13:38 EST, Alex Villacís Lasso
no flags Details

  None (edit)
Description Alex Villacís Lasso 2010-02-05 13:34:37 EST
Created attachment 389160 [details]
PCI description of machine as reported by lspci

Description of problem:
With distro kernel and KMS enabled (in default configuration), sometimes the graphics output will slow down and graphic updates become jerky and stuttering. This happened during the very F12 installation process on this machine, and continues with the most recent kernel/udev/Xorg versions as detailed below.

When this problem happens, a console login shows Xorg and udev taking lots of CPU time. The udev daemon, in particular, takes up 20% of CPU with priority -2 or -4, which ties up the rest of the processes. Also, /var/log/Xorg.0.log starts filling up with repetitive messages about EDID probes. My display is a LCD one at 1440x900 with a VGA connector, but I am not fiddling at all with my cables, or with the (currently unused) digital output, so there is no excuse for repeated EDID messages. 

I found that udev has a queue at /dev/.udev/queue.bin. On normal operation, this file is at most a few kb long. During one of these storms, the file grows alarmingly large (got a sample of almost 600 Kb).

With the current kernel, I might have a few hours of normal operation, and then the graphics slow down when moving windows and compiz enabled. By running a tail -f /var/log/Xorg.0.log I see that moving a big window around results in a bunch of EDID probe messages being sent to the log file (why???). With earlier kernels I might find the machine slows down without any user interaction whatsoever.

The only workaround I have found is to kill -9 udevd from a text console. After a few seconds the machine becomes responsive again.

Version-Release number of selected component (if applicable):
kernel-2.6.31.12-174.2.3.fc12.x86_64
udev-145-14.fc12.x86_64
xorg-x11-server-Xorg-1.7.4-1.fc12.x86_64
xorg-x11-drv-intel-2.9.1-1.fc12.x86_64

How reproducible:
Sometimes (might take a while of normal desktop use to manifest).

Steps to Reproduce:
1.
2.
3.
  
Actual results:
udevd and Xorg tie up CPU time and graphics output becomes jerky.

Expected results:
No CPU tying.

Additional info:
Smolt profile of machine at:
http://www.smolts.org/client/show/pub_15e9c41e-2f3d-41c0-aac8-ad554f4f50e5
Comment 1 Alex Villacís Lasso 2010-02-05 13:35:20 EST
Created attachment 389161 [details]
dmesg output on affected kernel
Comment 2 Alex Villacís Lasso 2010-02-05 13:37:16 EST
Created attachment 389162 [details]
Copy of /dev/.udev/queue.bin during probe storm

Hexdump of this file shows copies of the same event being sent over and over.
Comment 3 Alex Villacís Lasso 2010-02-05 13:38:33 EST
Created attachment 389163 [details]
Xorg log during episode of probe storm
Comment 4 Alex Villacís Lasso 2010-02-05 13:39:54 EST
I am currently running vanilla linux kernel 2.6.33-rc6 to check whether this issue appears in upstream kernel. So far I have seen no slowdowns.
Comment 5 Danny Yee 2010-02-15 16:18:19 EST
It seems to be in Ubuntu as well http://ubuntuforums.org/showthread.php?p=8775007

If you are using Intel video drivers, this is almost certainly a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=523646

I need to leave my mother with a stable working system before I go overseas, so I don't really want to play with non-standard kernels.
Comment 6 Alex Villacís Lasso 2010-02-17 10:53:41 EST

*** This bug has been marked as a duplicate of bug 523646 ***

Note You need to log in before you can comment on or make changes to this bug.