Bug 56227 - smrsh mailman wrapper fails after making a symlink in /etc/smrsh
smrsh mailman wrapper fails after making a symlink in /etc/smrsh
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-14 00:26 EST by Chris Yeo
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-11 17:56:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Yeo 2001-11-14 00:26:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90)

Description of problem:
I have upgraded my machine ("server") from 7.1.  I am running Mailman as a 
list server for one mailling list.  I did this prior to upgrading our 
office where I have multiple lists running on 7.1.

When you use the mailman product (available at http://www.list.org), you 
have to create entries in your alias file, which are just pipes to the 
mailman program.

When you send mail to the 'account', it gives an error : 
Nov 13 21:07:02 ns smrsh: uid 8: attempt to use wrapper.post.nbr-list

I have gone to the trouble of creating another pipe, and that one is to 
cat with 3 arguements.  It happens on this as well.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a piped alias (ex: test: "|/bin/cat arg1 arg2 arg3")
2. run newaliases
3. send mail to new piped alias
4. look in log file for a line like this:
Nov 13 23:11:31 ns smrsh: uid 8: attempt to use cat.arg1.arg2.arg3

	

Actual Results:  If I do exactly what is above then I get the error that 
is list there, if I create a new symlink in the /etc/smrsh directory (for 
the mail list) to be wrapper.mailowner.nbr-list that points to 
the /home/mailman/mail/wrapper, then I get this in the logs:

Nov 13 19:34:21 ns Mailman mail-wrapper: 
Usage: /etc/smrsh/wrapper.mailowner.nbr-list program [args...]


Expected Results:  I expected once I had setup the aliases, and put the 
symlink in /etc/smrsh then I would have a functional mail list.

Additional info:

Sendmail rpm version : sendmail-8.11.6-3

from /etc/aliases:

nbr-list:           "|/home/mailman/mail/wrapper post nbr-list"
nbr-list-admin:     "|/home/mailman/mail/wrapper mailowner nbr-list"
nbr-list-request:   "|/home/mailman/mail/wrapper mailcmd nbr-list"
nbr-list-owner:     nbr-list-admin
test-list:          "|/bin/cat arg1 arg2 arg3"

from /var/log/maillog:

Nov 13 23:11:31 ns sendmail[11315]: fAE5BUB11315: from=root, size=44, 
class=0, nrcpts=1, msgid=<200111140511.fAE5BUB11315@ns.biking.org>, 
relay=root@localhost

Nov 13 23:11:31 ns smrsh: uid 8: attempt to use cat.arg1.arg2.arg3

Nov 13 23:11:31 ns sendmail[11321]: fAE5BUB11315: to="|/bin/cat arg1 arg2 
arg3", ctladdr=test-list (8/0), delay=00:00:01, xdelay=00:00:00, 
mailer=prog, pri=30044, dsn=5.0.0, stat=Service unavailable

Nov 13 23:11:31 ns sendmail[11321]: fAE5BUB11315: fAE5BVA11321: DSN: 
Service unavailable
Comment 1 stone 2002-02-11 17:51:53 EST
wrapper symlink should look like:
wrapper -> /var/mailman/mail/wrapper
Comment 2 Chris Yeo 2002-02-11 17:56:32 EST
This is not a problem with sendmail, it turns out that it is a problem with 
Openmail, I have been able to recreate this problem with a new box that I am 
setting up.
Comment 3 Florian La Roche 2002-02-18 12:32:06 EST
Ok, closing this bug.

Thanks,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.