Bug 56229 - make bzImage Segmentation fault (program as)
Summary: make bzImage Segmentation fault (program as)
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-14 10:24 UTC by ym wong
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-14 10:24:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ym wong 2001-11-14 10:24:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10smp i686)

Description of problem:
on a SMP machine, I did a make xconfig, then make dep, make clean, and then
nohup make bzImage.
make failed with message.....
gcc -D__KERNEL__ -I/usr/src/linux-2.4.7-10/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fomit-frame-pointer
-fno-strict-aliasing -fno-common -Wno-unused -pipe
-mpreferred-stack-boundary=2 -march=i686    -c -o defkeymap.o defkeymap.c
gcc: Internal error: Segmentation fault (program as)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [defkeymap.o] Error 1
make[3]: Leaving directory `/usr/src/linux-2.4.7-10/drivers/char'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.7-10/drivers/char'
make[1]: *** [_subdir_char] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.7-10/drivers'
make: *** [_dir_drivers] Error 2
 

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1.make xconfig
2.make dep
3.make clean
nohup make bzImage

Actual Results:  segmentation fault from gcc

Expected Results:  bzImage created successfully

Additional info:

only tried twice. First time segmentation fault. second time bzImage
created

Comment 1 Jakub Jelinek 2001-11-14 10:37:36 UTC
If it is not reproduceable, it means hardware fault.
Try memtest86, if you have an athlon, try using i686 kernel, etc.


Note You need to log in before you can comment on or make changes to this bug.