Bug 562293 - [abrt] crash in Miro-2.5.4-1.fc12
Summary: [abrt] crash in Miro-2.5.4-1.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Miro
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6ee2ed39
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-05 20:39 UTC by Rafał Gliński
Modified: 2010-09-21 21:46 UTC (History)
6 users (show)

Fixed In Version: Miro-3.0.3-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-14 05:03:53 UTC


Attachments (Terms of Use)
File: backtrace (1.25 KB, text/plain)
2010-02-05 20:39 UTC, Rafał Gliński
no flags Details
fstab after several crashes of miro and working again (860 bytes, text/plain)
2010-09-21 21:46 UTC, Raphael Groner
no flags Details

Description Rafał Gliński 2010-02-05 20:39:04 UTC
abrt 1.0.4 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/miro.real
component: Miro
executable: /usr/bin/miro.real
kernel: 2.6.31.12-174.2.3.fc12.x86_64
package: Miro-2.5.4-1.fc12
release: Fedora release 12 (Constantine)

backtrace
-----
Summary: TB6ee2ed39 upgrade.py:77:upgrade:GError: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Not running within active session)

Traceback (most recent call last):
  File "/usr/bin/miro.real", line 48, in <module>
    upgrade.upgrade()
  File "/usr/lib64/python2.6/site-packages/miro/plat/upgrade.py", line 77, in upgrade
    if client.dir_exists("/apps/democracy/player") and not client.dir_exists("/apps/miro"):
GError: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Not running within active session)

Local variables in innermost frame:
old_file: '/root/.config/autostart/democracyplayer.desktop'
src: '/root/.democracy'
config_home: '~/.config'
dst: '/root/.miro'
destination: '/root/.config/autostart/miro.desktop'
autostart_dir: '/root/.config/autostart'
client: <gconf.Client object at 0x7fe7096a08c0 (GConfClient at 0x1b40000)>
_copy_gconf: <function _copy_gconf at 0x7fe70a75eed8>

Comment 1 Rafał Gliński 2010-02-05 20:39:07 UTC
Created attachment 389182 [details]
File: backtrace

Comment 2 Alex Lancaster 2010-02-08 23:13:06 UTC
Can you reliably reproduce this?  Please describe the exact conditions that
lead to the crash.  Crash reports without detailed information describing
exactly how to reproduce the bug are almost impossible to fix.

Comment 3 Louis van Dyk 2010-04-15 21:29:55 UTC

How to reproduce
-----
1. double click an avi file to play in miro
2.
3.


Comment
-----
The WAN link was very congested

Comment 4 Alex Lancaster 2010-04-15 21:45:03 UTC
(In reply to comment #3)
> 
> How to reproduce
> -----
> 1. double click an avi file to play in miro

That's really not specific enough.  Was it all avi files, or just particular one's that triggered this bug.  Can you provide a URL to download the particular troublesome avi fi.e

> The WAN link was very congested    

Not sure what you mean by this, do you mean that the network was congested as a result of clicking the file to play in Miro, or before?

Comment 5 Alex Lancaster 2010-04-15 21:50:42 UTC
Will: have you seen this bug before?  Several people have reported it.

(Incidentally I notice you are no longer on the bugzilla watchlist for Miro, is this intentional, or did you not get added to the recent branches (F-12 and later)?)

Comment 6 will kahn-greene 2010-04-15 22:13:05 UTC
(In reply to comment #5)
> Will: have you seen this bug before?  Several people have reported it.
> 
> (Incidentally I notice you are no longer on the bugzilla watchlist for Miro, is
> this intentional, or did you not get added to the recent branches (F-12 and
> later)?)    

I've never seen this before, but I'm not really sure what I'm looking at with this bug, either.

I didn't intentionally drop off a watchlist.  Is it the case that every time there's a new F, I have to sign up for a new watchlist?

Comment 7 Alex Lancaster 2010-04-16 02:12:13 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > Will: have you seen this bug before?  Several people have reported it.
> > 
> > (Incidentally I notice you are no longer on the bugzilla watchlist for Miro, is
> > this intentional, or did you not get added to the recent branches (F-12 and
> > later)?)    
> 
> I've never seen this before, but I'm not really sure what I'm looking at with
> this bug, either.
> 
> I didn't intentionally drop off a watchlist.  Is it the case that every time
> there's a new F, I have to sign up for a new watchlist?    

I think you need to be watching the "devel" (aka "rawhide") branch in order to be "rolled-over" from release to release.  Best thing to do would be add yourself as watchbugzilla and watchcommits on the devel, F-13, F-12 branches here:

https://admin.fedoraproject.org/pkgdb/acls/name/Miro

Comment 8 Louis van Dyk 2010-04-16 10:43:36 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > 
> > How to reproduce
> > -----
> > 1. double click an avi file to play in miro
> 
> That's really not specific enough.  Was it all avi files, or just particular
> one's that triggered this bug.  Can you provide a URL to download the
> particular troublesome avi fi.e
> 
> > The WAN link was very congested    
> 
> Not sure what you mean by this, do you mean that the network was congested as a
> result of clicking the file to play in Miro, or before?    

Hi Alex ... my apologies for being vague.

I can't confirm that all occurrences are for the same internal issue in Miro, but I frequently experience this:
1.  I have a 384k ADSL line.  I run ktorrent, and it's usually running at max incoming, but throttled to 7 kilobytes/sec upload.
2.  On an already downloaded file on my drive, I right-click on an AVI that I wish to watch (so it's not always the same file) and select "Open with Miro".  3.  Sometimes then Miro crashes and ABRT pops up.  But in last night's case, after it crashed I just tried again and then it worked (on the same file).

When it DOESN'T crash, it opens and then a green dot flicks next to the "Video" word on the left had panel.  I don't know if Miro is looking something up on the Web each time it opens.  That is why I thought that if my ADSL line was congested it might cause a timeout or host unreachable condition which might be the cause of the fault.  But that is guess-work on my part.

I will be sure to look out for more specifics next time it happens.

Regards
Louis

Comment 9 will kahn-greene 2010-04-16 16:55:40 UTC
(In reply to comment #8)
> I can't confirm that all occurrences are for the same internal issue in Miro,
> but I frequently experience this:
> 1.  I have a 384k ADSL line.  I run ktorrent, and it's usually running at max
> incoming, but throttled to 7 kilobytes/sec upload.
> 2.  On an already downloaded file on my drive, I right-click on an AVI that I
> wish to watch (so it's not always the same file) and select "Open with Miro". 
> 3.  Sometimes then Miro crashes and ABRT pops up.  But in last night's case,
> after it crashed I just tried again and then it worked (on the same file).
> 
> When it DOESN'T crash, it opens and then a green dot flicks next to the "Video"
> word on the left had panel.  I don't know if Miro is looking something up on
> the Web each time it opens.  That is why I thought that if my ADSL line was
> congested it might cause a timeout or host unreachable condition which might be
> the cause of the fault.  But that is guess-work on my part.
> 
> I will be sure to look out for more specifics next time it happens.

The error in the bug description is a gconf error where gconf is trying to access its data and can't.

Is your home directory on an NFS mount or something like that?  What's unusual about your system setup?

Comment 10 Louis van Dyk 2010-04-16 17:36:22 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > I can't confirm that all occurrences are for the same internal issue in Miro,
> > but I frequently experience this:
> > 1.  I have a 384k ADSL line.  I run ktorrent, and it's usually running at max
> > incoming, but throttled to 7 kilobytes/sec upload.
> > 2.  On an already downloaded file on my drive, I right-click on an AVI that I
> > wish to watch (so it's not always the same file) and select "Open with Miro". 
> > 3.  Sometimes then Miro crashes and ABRT pops up.  But in last night's case,
> > after it crashed I just tried again and then it worked (on the same file).
> > 
> > When it DOESN'T crash, it opens and then a green dot flicks next to the "Video"
> > word on the left had panel.  I don't know if Miro is looking something up on
> > the Web each time it opens.  That is why I thought that if my ADSL line was
> > congested it might cause a timeout or host unreachable condition which might be
> > the cause of the fault.  But that is guess-work on my part.
> > 
> > I will be sure to look out for more specifics next time it happens.
> 
> The error in the bug description is a gconf error where gconf is trying to
> access its data and can't.
> 
> Is your home directory on an NFS mount or something like that?  What's unusual
> about your system setup?    

The system was upgraded from Fedora 10 to 11 and then to 12. It has two additrional ext3 partitions mounted under /mnt/a2 and /mnt/b1. I download to my home folder and move to these two mounts. The motherboard had to be chbnaged while on F11. It was always 64 bit buT has gone from AMD cpu with ATI GPU to Intel cpu and onboard intel gpu.

I can't think of anythinng else.

Comment 11 Alex Lancaster 2010-07-18 08:47:32 UTC
Reporter: can you still reproduce this in the current version of Miro: 3.0.2?  If not, or if I don't hear a response within 1 week, I'll close this bug.  If you can reproduce you're always free to re-open it.

Comment 12 Fedora Update System 2010-08-29 17:19:14 UTC
Miro-3.0.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc14

Comment 13 Fedora Update System 2010-08-29 17:26:19 UTC
Miro-3.0.3-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc13

Comment 14 Fedora Update System 2010-08-29 17:30:25 UTC
Miro-3.0.3-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc12

Comment 15 Fedora Update System 2010-08-30 19:41:00 UTC
Miro-3.0.3-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/Miro-3.0.3-1.fc14

Comment 16 Fedora Update System 2010-09-14 05:01:55 UTC
Miro-3.0.3-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2010-09-15 05:33:49 UTC
Miro-3.0.3-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-09-15 05:48:57 UTC
Miro-3.0.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Raphael Groner 2010-09-20 11:02:36 UTC
I would like to reopen this bug cause abrt found it for my issue.

upgrade.py:77:upgrade:GError: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Server ping error: IDL:omg.org/CORBA/COMM_FAILURE:1.0)

Traceback (most recent call last):
  File "/usr/bin/miro.real", line 48, in <module>
    upgrade.upgrade()
  File "/usr/lib64/python2.6/site-packages/miro/plat/upgrade.py", line 77, in upgrade
    if client.dir_exists("/apps/democracy/player") and not client.dir_exists("/apps/miro"):
GError: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Server ping error: IDL:omg.org/CORBA/COMM_FAILURE:1.0)

Local variables in innermost frame:
old_file: '/home/raphael/.config/autostart/democracyplayer.desktop'
src: '/home/raphael/.democracy'
config_home: '~/.config'
dst: '/home/raphael/.miro'
destination: '/home/raphael/.config/autostart/miro.desktop'
autostart_dir: '/home/raphael/.config/autostart'
client: <gconf.Client object at 0x1e61550 (GConfClient at 0x1ea9860)>
_copy_gconf: <function _copy_gconf at 0x1d662a8>

Comment 20 Raphael Groner 2010-09-20 11:04:09 UTC
(In reply to comment #19)
And it is reproducable always with every try to start Miro ...

Comment 21 Michel Alexandre Salim 2010-09-20 11:31:14 UTC
Hi Raphael,

are you saying the issue happens to you with Miro 2.5.4 or with Miro 3.0.3? If the former, please update (the update is available on F-12 too, see comment #17). If the latter, then do reopen.

How are you running Miro -- are you in a graphical desktop? which one (GNOME/KDE/XFCE/LXDE/...)? accessing locally or remotely? Could you provide the output of 

   ps auxwww | grep gconf

just after the crash?

Comment 22 Raphael Groner 2010-09-20 12:24:45 UTC
(In reply to comment #21)
Miro-3.0.3-1.fc13.x86_64

Linux schlebby 2.6.34.6-54.fc13.x86_64 #1 SMP Sun Sep 5 17:16:27 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

LXDE

raphael   1935  0.0  0.0 131532  1032 ?        S    Sep17   0:00 /usr/libexec/gconfd-2
raphael  26246  0.0  0.0 105272   808 pts/1    S+   14:23   0:00 grep gconf

Comment 23 Raphael Groner 2010-09-20 12:25:38 UTC
(In reply to comment #22)
Errr, i mean XFCE, not LXDE ... Sorry.

Comment 24 Michel Alexandre Salim 2010-09-20 13:28:43 UTC
OK. I'll install XFCE on my F-13 machine and try and reproduce this.

Comment 25 Raphael Groner 2010-09-20 17:13:39 UTC
Interesting. When I try to open an .avi movie directly with Miro, it just works fine.

Comment 26 Michel Alexandre Salim 2010-09-21 19:39:34 UTC
So, to summarize:
- "$ miro /path/to/movie.avi" works
- "$ miro" fails as you describe

I've not been able to replicate the problem using XFCE on an F-13 box -- Miro works just fine. Could you provide the following:

- content of /etc/fstab
- ls -l / | grep tmp
- and whether the problem still occurs if you do rm -rf /tmp/* , restart the machine, and retry
- whether it affects any other application, like Firefox

Many thanks!

Comment 27 Raphael Groner 2010-09-21 21:45:25 UTC
(In reply to comment #26)
To be honest, it works again like a charme (maybe fixed mystically while I tried to open an avi directly).

drwxrwxrwt.  20 root root   4096 21. Sep 23:23 tmp

... yes, I use some cleaning script for /tmp and /var/tmp that deletes files older than last access was some days ago or something like that. So, maybe a corrupted tmp file was the cause, dunno.

Firefox? I try to use Midori mostly.

Comment 28 Raphael Groner 2010-09-21 21:46:32 UTC
Created attachment 448816 [details]
fstab after several crashes of miro and working again


Note You need to log in before you can comment on or make changes to this bug.