Bug 562317 - [abrt] crash in easytag-2.1.6-2.fc12
Summary: [abrt] crash in easytag-2.1.6-2.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: easytag
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c100e3f78ebbd2425aeb2858af8...
: 558278 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-05 22:19 UTC by Kerry
Modified: 2010-05-12 18:02 UTC (History)
2 users (show)

Fixed In Version: easytag-2.1.6-5.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-12 17:52:52 UTC


Attachments (Terms of Use)
File: backtrace (12.18 KB, text/plain)
2010-02-05 22:19 UTC, Kerry
no flags Details

Description Kerry 2010-02-05 22:19:31 UTC
abrt 1.0.4 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: easytag
component: easytag
executable: /usr/bin/easytag
kernel: 2.6.31.12-174.2.3.fc12.i686.PAE
package: easytag-2.1.6-2.fc12
rating: 4
reason: Process was terminated by signal 6 (Aborted)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Misc | load filenames from txt
2. open, select file, load
3. Crashes when pressing apply

Comment 1 Kerry 2010-02-05 22:19:33 UTC
Created attachment 389208 [details]
File: backtrace

Comment 2 Kerry 2010-02-10 06:07:46 UTC
Apparently there is a fix for this:

http://old.nabble.com/crash-w-Load-Filenames-from-TXT-on-2.1.4-td26975039.html

This issue is present in easytag 2.1.6 too (Jérôme said it will be solved in 2.1.7). Temporary fix is to change the line 3330 in file "misc.c". Change:
g_free(currentPath);
to this:
gtk_tree_path_free(currentPath);
and then compile. With this correction, Load filenames from .txt file feature works fine.

Comment 3 Matthias Saou 2010-04-30 14:59:40 UTC
Thanks a lot for the report and the link to the fix.

Comment 4 Matthias Saou 2010-04-30 15:02:56 UTC
*** Bug 558278 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2010-05-03 08:29:23 UTC
easytag-2.1.6-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/easytag-2.1.6-5.fc12

Comment 6 Fedora Update System 2010-05-03 08:29:38 UTC
easytag-2.1.6-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/easytag-2.1.6-5.fc13

Comment 7 Fedora Update System 2010-05-03 08:29:50 UTC
easytag-2.1.6-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/easytag-2.1.6-5.fc11

Comment 8 Fedora Update System 2010-05-04 06:15:46 UTC
easytag-2.1.6-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update easytag'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/easytag-2.1.6-5.fc13

Comment 9 Fedora Update System 2010-05-04 06:17:15 UTC
easytag-2.1.6-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update easytag'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/easytag-2.1.6-5.fc12

Comment 10 Fedora Update System 2010-05-04 06:23:44 UTC
easytag-2.1.6-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update easytag'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/easytag-2.1.6-5.fc11

Comment 11 Fedora Update System 2010-05-12 17:52:38 UTC
easytag-2.1.6-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2010-05-12 18:00:07 UTC
easytag-2.1.6-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2010-05-12 18:02:18 UTC
easytag-2.1.6-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.