Bug 56235 - Show Stopper!! Up2date doesn't understand enterprise entitlements
Show Stopper!! Up2date doesn't understand enterprise entitlements
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
RHN Devel
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-14 08:41 EST by Jay Turner
Modified: 2015-01-07 18:52 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-07 13:33:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2001-11-14 08:41:13 EST
Description of Problem:
If you run up2date on a system which has an enterprise entitlement as
opposed to a personal entitlement, then you will get error code 31 (system
not entitled.)

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Peter Jones 2001-11-14 11:36:00 EST
I'm not exactly sure who's bug this is.  The question is this: If all enterprise
entitlements are also supposed to provide "update assistant" functionality, why
don't we just make the product provide one of each?

I was told not to do this, of course, but it may still be the right answer...
Comment 2 Adrian Likins 2001-11-14 12:10:26 EST
what exactly is it that the client should be doing different in this case?

I'm not aware of any difference in the way system ids are created for
enterprise setups or otherwise.
Comment 3 Cristian Gafton 2001-11-14 13:14:14 EST
this is teh server side - I am looking explicitly for the label of the software
manager service

might be usefull to hack in some sort of mapping that for each groupid that is
used in entitlement we add a flag that tells us whether up2date is functioning
or not - or figure out how to implement roles.

right now looks like we have three services that are being provided: Software
manager, update assistant and Systems Manager. As we add more we'll need to be
able to qualify those roles somehow.
Comment 4 Jay Turner 2001-11-14 14:07:42 EST
Changing this to the correct component.
Comment 5 Greg DeKoenigsberg 2001-11-27 16:46:16 EST
In the web code, the standard emerging method for telling if a system is
viewable is to see if the entitlement check returns "none" or not.

As entitlements change, I'm guessing that the one constant rule will be this:
any system that is in *any* way entitled to RHN will be entitled to receive
updates.  Therefore, the "none" check should remain valid in all cases.
Comment 6 Greg DeKoenigsberg 2001-12-18 12:18:16 EST
Jay, has this bug been closed?
Comment 7 Greg DeKoenigsberg 2002-03-07 13:33:29 EST
This bug could not possibly still be open.
Comment 8 Jay Turner 2002-05-15 08:46:12 EDT
Indeed, this has been fixed for quite some time.  Closing out.

Note You need to log in before you can comment on or make changes to this bug.