Bug 56236 - Failed logic on the "Update Now" functionality
Summary: Failed logic on the "Update Now" functionality
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site   
(Show other bugs)
Version: RHN Devel
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Chip Turner
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-14 13:49 UTC by Jay Turner
Modified: 2015-01-07 23:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-26 18:15:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Turner 2001-11-14 13:49:44 UTC
Description of Problem:
We are presenting an "Update Now" link on the
/network/systemlist/system_list_detailed.pxt page which works great for
most cases.  However, I have a case where the profile only needs 7
upgradeable packages, and clicking Update Now is attempting to schedule
errata update actions.  I'm thinking that if the only thing the profile
needs are upgradable packages, then we should not present the link, as
technically the machine in up-to-date already.

Will be a bit confusing to the user otherwise.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. Log into https://rhn.webdev.redhat.com as rhn7_mocha
2. Pull up the System List, then click the Detailed link in the upper-right
   corner
3. Check out the haring.devel.redhat.com profile

Actual Results:


Expected Results:


Additional Information:

Comment 1 Chip Turner 2001-11-26 18:15:43 UTC
this seems to be fixed in CVS already

Comment 2 Jay Turner 2001-11-26 22:45:08 UTC
OK, we are no longer attempting to schedule updates for the outdated packages on
https://rhn.webdev.  Let's push this to webqa.


Note You need to log in before you can comment on or make changes to this bug.