Bug 56242 - Xconfigurator should support generic VESA driver
Xconfigurator should support generic VESA driver
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-14 10:38 EST by Toralf
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-15 00:07:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2001-11-14 10:38:26 EST
Description of Problem:

We have a laptop with a graphics chipset that isn't supported by any of the
card specfic XFree86 drivers. Xconfigurator suggests using "trident"
driver, but X just doesn't start with it.

It turns out that the Generic VESA driver works fine, though, but there
appears to be no way to select it in Xconfigurator; I had to edit
/etc/X11/XF86Config-4 by hand (after skipping test in Xconfigurator), replacing
	Driver "trident"
with
	Driver "vesa"
in order to enable it.

Version-Release number of selected component (if applicable):
4.9.39-1


How Reproducible:
Every time

Steps to Reproduce:
1. Xconfigurator [--expert] --preferxf4
2. Set up monitor parameters and resolutions as required
 

Actual Results:
X test failes; VESA driver can't be selected, even in expert mode.

Expected Results:
Ideally, the user should be lead towards the VESA driver when test with the
"real" one fails. If that can't be done, manual driver selection oucht to
be supported, at least in expert mode.

Additional Information:
The machine in question is a Toshiba Satellite Pro 4600.
Comment 1 Mike A. Harris 2002-05-21 02:02:34 EDT
The VESA driver can be selected in Xconfigurator in Red Hat Linux 7.3.
I thought it was also available in 7.2, but it might have been added
during 7.3 development.

Note You need to log in before you can comment on or make changes to this bug.