Bug 562427 - [abrt] crash in openoffice.org-writer-1:3.1.1-19.14.fc12
[abrt] crash in openoffice.org-writer-1:3.1.1-19.14.fc12
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:2f065c4100bbb34ac30b90df267...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-06 12:00 EST by Artem Prokshin
Modified: 2010-02-12 09:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-12 09:14:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (21.49 KB, text/plain)
2010-02-06 12:00 EST, Artem Prokshin
no flags Details

  None (edit)
Description Artem Prokshin 2010-02-06 12:00:20 EST
abrt 1.0.4 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/swriter.bin -writer file:///home/artem/%D0%A0%D0%B0%D0%B1%D0%BE%D1%87%D0%B8%D0%B9%20%D1%81%D1%82%D0%BE%D0%BB/%D0%A2%D1%80%D0%B5%D0%B1%D0%BE%D0%B2%D0%B0%D0%BD%D0%B8%D1%8F%20%D0%BC%D0%B5%D1%82%D0%BE%D0%B4%D0%B8%D1%87%D0%BA%D0%B8.doc
component: openoffice.org
executable: /usr/lib64/openoffice.org3/program/swriter.bin
kernel: 2.6.31.6-166.fc12.x86_64
package: openoffice.org-writer-1:3.1.1-19.14.fc12
rating: 2
reason: Process was terminated by signal 11
release: Fedora release 12 (Constantine)
Comment 1 Artem Prokshin 2010-02-06 12:00:25 EST
Created attachment 389294 [details]
File: backtrace
Comment 2 Caolan McNamara 2010-02-06 14:41:05 EST
No symbol info the bt, and its from an older version of abrt that doesn't include the load addresses of the shared libraries :-( so I can't be sure of the exact location of the crash.

But it's something to do with dragging the margins of the page around. Does that sound familiar to you, are you able to reproduce this crash ?
Comment 3 Artem Prokshin 2010-02-08 08:20:35 EST
abrt with openoffice's crash has asked me to install extra debug libraries.
I have installed them.
and than abrt hangs itself for a while. Once I got abrt working I did the best I could.
I do not remember right now the cause of the crash. I remember one thing I had worked on MSWords document, with autofigures.

And give me please a little guidance how could I figure out all necessary debug library is installed properly.
Comment 4 David Tardon 2010-02-08 08:36:22 EST
dtardon->taybola: The required debuginfo packages can be installed by running

debuginfo-install openoffice.org-*

as root. But if your system hasn't been updated for a long time, a lot of them would be for newer revisions of the packages, therefore unusable. Unfortunately Fedora mirrors doesn't keep old revisions of packages.
Comment 5 Caolan McNamara 2010-02-08 09:13:47 EST
The most relevant thing is if you can get it to happen again. If you know how to get it to happen again, e.g. with moving the margins of a particular document then that'd be the most important thing. e.g. "move margins of page X of this document"
Comment 6 Artem Prokshin 2010-02-08 15:26:52 EST
I'm putting debuginfo-install openoffice.org-* on my box. It'll take a while.
How can I decode file:///home/artem/%D0%A0%D0%B0%D0%B1%D0%BE%D1%87%D0%B8%D0%B9%20%D1%81%D1%82%D0%BE%D0%BB/%D0%A2%D1%80%D0%B5%D0%B1%D0%BE%D0%B2%D0%B0%D0%BD%D0%B8%D1%8F%20%D0%BC%D0%B5%D1%82%D0%BE%D0%B4%D0%B8%D1%87%D0%BA%D0%B8.doc
this string to Russian. I have tried insert the string into firefox without lack.
I'm guessing I already sent this document to editor for publishing and it's gone.
Comment 7 Caolan McNamara 2010-02-09 09:21:31 EST
The file that OOo was *launched* to open was...
/home/artem/Рабочий стол/Требования методички.doc
but you may of course have opened another different document afterwards. So its no guarantee that the above doc was the one that caused the crash, but its worth a shot at least.
Comment 8 Artem Prokshin 2010-02-10 15:05:05 EST
First of all I have installed "debuginfo-install openoffice.org-*" on my box.

"Требования методички.doc" is from the publisher and has requirements for document's publishing.
One of them is: height of plain text plus bottom column title should be 250 mm.
The document itself obeys the same requirement. Actually I did not edit this doc, not I, at least specially.
Guessing that I enlarge this document and move horizontal scroll to get plan text close to left ruler to make sure the height of plain text plus bottom columntitle is 250 mm. And entered couple times to plain text area and to columntitles areas.
I have played with this doc right now, enlarged, move h.scroll but without luck.
Comment 9 Caolan McNamara 2010-02-12 09:14:57 EST
Fiddled around with the scrollbars and dragged the page margins area around in a sample document under a valgrind session with nothing suspicious. Can't reproduce :-(. If you find a way to make it happen again feel free to reopen this issue with the extra information, thanks for you efforts.

Note You need to log in before you can comment on or make changes to this bug.