Bug 56245 - mouseconfig/redhat-config-mouse should support connection of multiple mice
mouseconfig/redhat-config-mouse should support connection of multiple mice
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-mouse (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-14 11:05 EST by Toralf
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-14 15:43:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2001-11-14 11:05:35 EST
Description of Problem:
XFree86 can quite easily be set up in such a way that it will
simultaneously accept input from several different mice connected to
different ports. It would be very nice if mouseconfig could support such a
setup, too.

I'm mainly using this feature of XFree86 in order to allow an external
mouse to be connected to a laptop, and taken into use withough rebooting or
reconfiguring. I've got it all working via manual updates to
/etc/X11/XF86config-4; I have one pointer entry for PS/2 (i.e. the internal
device), and one for USB (where I connect the external one). The problem is
that this configuration gets messed up every time I run "mouseconfig" or
"Xconfigurator".

Version-Release number of selected component (if applicable):
4.23-1
Comment 1 Brent Fox 2002-10-10 14:14:46 EDT
I have just completed a text mode interface for redhat-config-mouse, which means
that mouseconfig will be deprecated in the next release of Red Hat Linux.  

Therefore, I will not be putting any development time towards fixing mouseconfig
bugs, so I'm closing this as 'wontfix'.
Comment 2 Toralf 2003-04-30 15:58:24 EDT
As far as I can tell, redhat-config-mouse doesn't have this functionality,
either. Reopening with new product and OS version.
Comment 3 Brent Fox 2003-05-01 12:50:57 EDT
redhat-config-mouse does accept input from multiple mice.  It's not really clear
in the interface, but it should set up /etc/sysconfig/mouse and
/etc/X11/XF86Config with the right multiple settings.  What mice combinations
are not working for you?
Comment 4 Toralf 2003-05-02 13:59:07 EDT
I'm testing with a Logitech cordless mouse + keyboard connected to the PS/2
mouse, and another Logitech (wheel) mouse connected to via USB. But maybe the
problem isn't redhat-config-mouse; I've now tested a bit more, and got all sorts
of weird behaviour, like the keyboard not working after the mouse is
disconnected, which I guess point towards a hardware or driver problem. When I
think about it, I remember seeing unexpected results like this in the past, too,
for keyboard + mouse combos.

Anyhow, this is just a test setup; what I really want to work, is the internal
pointer device *and* a USB mouse (Logitech Wheel) on a Toshiba laptop, but I
haven't been able to test Red Hat 8.0 or 9 with that configuration yet.
Comment 5 Brent Fox 2003-05-22 11:44:59 EDT
Hmmm, I can't explain the keyboard problem.  Anyway, if you want a ps/2 and a
usb mouse to work at the same time, run redhat-config-mouse and pick the ps/2 as
the default mouse.  That will set up both the ps/2 and the usb mouse.

There is a bug in that if you pick the USB mouse in the list, only the USB mouse
will work, but if you pick the ps/2, then both will work.  I will try to fix
this when I get a chance.
Comment 6 Toralf 2003-05-23 05:27:09 EDT
The keyboard behaviour really baffles me, but I guess the setup may be wired in
an odd odd manner, since there is a common IR tranciever for the keyboard and
mice, with only one cable to it.

Anyhow, I've now been able to test on the final setup, and it acually does
accept input from both pointer devices when I set it up the way you say. I still
don't feel the config tool gives me a lot of control over the setup though. In
particular, it's not clear to me how I set parameters for each of the mice (note
that they are quite different, as the internal device has only two buttons,
while the USB unit is typically a 3-button mouse with scroll wheel.)
Comment 7 Brent Fox 2003-07-14 15:43:13 EDT
You're right...it doesn't give you total control over both devices but it's not
designed to.  The goal is to get a basic mouse configuration so that people can
have a working mouse setup.  If they need to do more customization, they can
learn about modifying the XF86Config file manually.  

Basically, there are so many different kinds of mice that it would be impossible
to write one config tool that allowed fine-grained control for all of them.  So,
the idea is to make a config tool that makes the common case simple.  

Note You need to log in before you can comment on or make changes to this bug.