Bug 562451 - "ls -a" hangs terminals
"ls -a" hangs terminals
Status: CLOSED DUPLICATE of bug 493565
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-06 14:51 EST by Steven Usdansky
Modified: 2015-03-03 17:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-17 05:07:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Usdansky 2010-02-06 14:51:42 EST
Description of problem:
Logged in as an ordinary user, entering "ls -a" in a terminal window in GNOME hangs the terminal. The process just sits there. Here's the output from ps aux:
a       2195  0.0  0.0 115224   836 pts/1    S+   13:43   0:00 ls --color=auto -a

Version-Release number of selected component (if applicable):
(Rawhide updated 6-Feb-2010)
gvfs-1.5.2-4.fc13.x86_64
gvfs-fuse-1.5.2-4.fc13.x86_64

How reproducible:
99% of the time

Steps to Reproduce:
1. open a terminal window
2. ls -al
 
Actual results:
Terminal hangs

Expected results:
complete directory listing

Additional info:
If I kill all gvfs processes and unmount ~/.gvfs, the command works properly. I have never had this problem as root.

Additionally:
1. Boot into runlevel 3
2. startx
3. open a terminal window and run ls -a
4. open a second window and kill the job from step 3
5. exit GNOME (back to a tty; some gvfs processes still running)
6. ls -a
7. tty hangs
Comment 1 Tomáš Bžatek 2010-02-17 05:07:14 EST

*** This bug has been marked as a duplicate of bug 493565 ***

Note You need to log in before you can comment on or make changes to this bug.